Modeling Cloth Addon for Blender 2.8


Modeling cloth is out for blender 2.8
There are lots of fun new features.
I tested it on the 2.8 build today and it worked but blender is changing a lot so let me know if you have trouble getting to run.

[Free on Github]https://github.com/the3dadvantage/Modeling-Cloth-2_8/archive/master.zip
Donate to help support me making cool addons
Patreon
Buy on Blender market
buy on gumroad
My github

Special thanks to Rico Cilliers for the artwork!!!

36 Likes

Very nice! And thanks for making a free option. Will donate when I can but I just spent way too much on the Blender market spring sale :stuck_out_tongue:

1 Like

This looks amazing! Thank you for sharing the addon for free, I’ll definitely buy it on the blendermarket as soon as I get my next payment :slight_smile:

I played with it a bit and it works great!
I haven’t seen the whole video yet but is there a way to set up the resolution of the mesh without going into edit mode? It would be great to be able to start with something simple and then upres the mesh without redoing the whole sim, kinda like Marvelous Designer

Also, how can I setup friction? I couldn’t find any setting for it

Thanks again!

It is amazing! I tried to use it for MB-Lab Character , but it doesn’t work, can I use it with MB-Lab Character ?

If you go into the modeling cloth shape key in edit mode you can subdivide it without losing the current state.

The collision system is super basic so no friction setting. It’s going on the list of requested features. I’ll keep developing.

Thanks!

I haven’t tried it with and MB lab character. I think there is a bug where armature changes are seen by the cloth sim. Try making a mesh with all the modifiers applied. I’ll add a bug report about armature transforms.

Thanks!

Thanks for your answer, I’ll keep experimenting with it :slight_smile: Do you have a list of future/possible features anywhere?

Have you seen this GSOC project? https://wiki.blender.org/wiki/User:Ishbosamiya/GSoC2019/Proposal


Not having to worry about the mesh resolution would be a great addition to this tool!

Thank you for your reply!

When I use Grab I get this error:

Traceback (most recent call last):
File “/usr/local/Blender/blender-2.80.0-git20181204.1b6a394d862-x86_64/blender280.app/Contents/Resources/2.80/scripts/addons/Modeling-Cloth-2_8-master/ModelingCloth28.py”, line 2560, in modal
main_drag(context, event)
File “/usr/local/Blender/blender-2.80.0-git20181204.1b6a394d862-x86_64/blender280.app/Contents/Resources/2.80/scripts/addons/Modeling-Cloth-2_8-master/ModelingCloth28.py”, line 2504, in main_drag
bpy.context.evaluated_depsgraph_get()
AttributeError: ‘Context’ object has no attribute ‘evaluated_depsgraph_get’

Mac Os Blender 2.80

It’s only in the newest blender 2.8 builds. Get the latest and it should work. Let me know if it doesn’t.
Thanks!

Was wondering if this can be applied to cables/ropes, giving some basic physic/collision while preventing the collapsing of their radius at the same time.

I actually wrote a separate collision system that would do that nicely. It’s currently disabled in the code. I’ll put it on the list of features that need to be developed.

Best!

2 Likes

Unbelievable what you got in your addon. I did not know that it would be possible to extract so many resources from Blender. Congratulations on making so many resources available in a free way. In the same way I hope that professionals who will greatly gain from their addon can make some value available in recognition of their work. I hope that at least part of this addon can remain free to the blender community. Addons like yours are what makes Blender even more powerful.

1 Like

I was planning to keep it free. That way no one can steal the code. What’s to steal?
People have been donating and supporting. I really hope to get enough support to make addons full time.
I’ve made my living off of blender for more than ten years now so why wouldn’t I want to give back? I really like the open source model!

17 Likes

Hi, I’ve been experimenting with this over the past couple days and overall it is awesome! There is one thing that is quite annoying that I’ve kept running into though, which is that if you ever use the undo shortcut to go back on anything that happened in the simulation, it completely borks things and I have to delete the object I was working on completely and remake it, or even delete it then restart blender, before it will work again. No amount of resetting or removing animation cloth state and then re adding it to the same object seems to fix it. Also it was not obvious to me at first that you need to click the Modeling Cloth button (i.e. convert it to modeling cloth object) while in edit mode with all the verts selected, rather than in object mode.

Oh also, I was getting the same error @kabu was getting on the latest blender 2.8 builds, but it would only happen if I had already borked it by undoing (or something else). Then if I put on continuous and used grab tool, it would give me that same exception. Normally it worked fine.

hmm… Should be able to turn on modeling cloth in edit or object mode. Selection of verts shouldn’t make a difference. I’ll have to double check that.
The undo thing is at least partially because blender 2.8 (I assume you’re using 2.8) is still a little buggy with undo. I will do some testing and put in a bug report right now based on your comments.
Thanks for the feedback!!!

1 Like

Thanks! Here’s a test scene -> https://mega.nz/#!ScQAhQ4B!IBw332lt8_wFPhR44d6wBnd1587gkHKGfAZ8mOR3fp8

Steps to reproduce object mode apply not working:

  1. Duplicate “top template base”
  2. Apply modifiers and subdivide it a couple times in edit mode
  3. duplicate it to the other side of her in edit mode
  4. Go to object mode, apply modeling cloth to the object
  5. go back into edit mode, add sew lines to a couple places
  6. Start continuous mode and nothing happens

(step 5 might not be necessary, didn’t test)

This is amazing. Can’t wait to use this.

Oops. Replied in the wrong spot