Modo-Me, Modo like action centers in Blender, Smart Action Centers and Axis Management

it would be great if you provided a Modo example for your posts too … because I’m a Modo user and don’t understand a bit what you are explaining … this is about the last post

Figured it out what you meant, I think, this what you looking for.
Strange behavior for 3D Cursor this is usually for blender when origin is in random rotation, may be it will be fixed when developers fix calculating Normals.

P.S. sorry for not Modo-Me addon usage in video

No, I am not talking about the cursor, I meant moving the center and aligning it to an element…here is a video:

You can use
Object - Set Origin - Origin to 3D Cursor
but as you can see on video below, 3D Cursor can’t figure out Normals correctly when origin in random rotation

but when you setup 3D Cursor somehow properly and use “Origin to 3D Cursor” it just move to that position and did not copy rotations…
May be I forgot something to do…need gurus help, or it can’t be done without custom addon for this specific purposes.
Found this
but think they went in wrong direction there…

For simple move Pivot to Selection you can use this, but it just move and did not affect rotation or normals

P.S. and again sorry for offtop, may be it better to move this discussion to another topic.

Aligning to selection is mostly a Blender issue, although I coded couple custom methods in there to ease the issue especially with the component mode.

For now the best way is to use the component mode to align it the way you want then set your selection again. Lets say you have a a complex selection and you want it to align to one of edges or a polygon, select that first then use the component mode (this does not exist in Modo but in Modo-Me), then back to edit mode, then do your real selection. I will add an option to keep the component mode in edit mode.

I realize that is a drag a bit but the thing is finding good alignment for arbitrary shapes (the shape of a whole selection) is not an easy issue. Because figuring out a pleasing angle that consitutes the direction is the issue here. This will be resolved over time hopefully.

For some of that functionality you might want to check out my Originie add-on.

There is also a bounding box option (at the bottom of the menu atm) in Modo-Me, for positioning the cursor to bounding faces of the volume. It does not consider the selection for now, something I can add later.

Having used Modo a while ago and recently missing the ability to easily pick action centres and axis for transforms, this might be just what I’m looking for.

What is the difference between this add-on and your Originie Pivot Transform add-on?



The Originie add-on is only concerned about the actual pivot of the object, and has couple additional helpful functions. On the other hand Modo-Me never modifies the actual pivot/origin of the object and it is all about the action centers as in where the transform gizmo is and how it is oriented.

Basically if you do not want to modify the pivot during operations but still be able to have control over the gizmo then Modo-Me offers bunch of options. However if you need to control where the actual pivot of the object frequently then Originie is the way to go.

Bear in mind that you have an option to make the transform gizmo to respect the pivot (or use it as the center of transforms), in that case Originie can be helpful too.

1 Like

Thanks for clarifying @kkar. Appreciate it.

For me, control over the action centres and axis sounds great.

1 Like

Once ive used the modo-me to get the pivot to be where i want it to be, how do i change the gizmo back to standard move etc, rather than having the multiple transform gizmo active?

I need to take a look at it. I might need to rework the gizmo stuff there. Is it overriding your initial Gizmo choice?


I just purchased Modo-Me on Gumroad, but unfortunately I can not get it working.
When hitting the mapped Key Blender gives me ‘object.modoactioncenters not found’.
I tried both object.modoactioncenters and ‘OBJECT_MT_modoactioncenters’ in ‘Name’.

My Specs:
Blender 2.82.1
Windows 10 Latest Update
Install Folder: C:\Program Files\Blender Foundation\Blender\2.80\scripts\addons\Modo-Me
Tried both Beta_2.80_v1.54_10012019 and ModoMe_2.80_2.79_v1.50_07242019


I think you referenced an older version of the Readme. That had to change with the recent versions of Blender,

Please use OBJECT_MT_modoactioncenters

For versions prior to 1.52

Put wm.call_menu at the top left box in the new keymap area, once done the bottom box will open up. And paste object.modoactioncenters into the box that is on the right side (one that is with Name:)

For versions 1.52 and above

Put wm.call_menu at the top left box in the new keymap area, once done the bottom box will open up. And paste OBJECT_MT_modoactioncenters into the box that is on the right side (one that is with Name:)

Please let me know if you have further issues with installation.


Thanks for your fast reply :slight_smile:

I tried “OBJECT_MT_modoactioncenters” again, but it still doesn’t work -> ‘object.modoactioncenters not found’ on Hotkey

Blender 2.82
C:\Program Files\Blender Foundation\Blender 2.82\2.82\scripts\addons\Modo-Me\

You need to use v1.54 to make that new menu function to be in place. That version is almost a year old.

Juat remove the whole Modo-Me folder. And restart Blender and start fresh with installating the latest version, it should work. I use it here daily.

still not working
Also tried my other PC with fresh Blender install

Couple of things to check:

  • By any chance did you forget to enable the add-on?
  • Do you have any other hotkeys also assigned to that key combination that may be overriding it?

I’ve been using 1.54 on 2.83 with no issues and my key assignment looks identical to yours.

1 Like

Sorry about that.

Can you PM me the screenshot of the addon’s install tab, Blenders startup screen?

Remove all traces of the addon, restart Blender. Install the add-on and enable the add-on

I just tried the steps above here and it works.

Now there is a mistake in the Readme because I changed it from wm.call_menu to wm.call_menu_pie in the recent versions to open up more space for other functions and it still refers to the old function. So use the pie version.

See the image please

Btw the add-on already comes with alt - w, try that also. If that does not work, the addon is not installed properly


Steps taken:

  • Uninstalled Blender
  • Deleted both Blender Addons Folder and Blender Folder in Roaming
  • Installed Addon
  • Success

Thanks again for your quick response and your effort. Fantastic :slight_smile:



I found the issue. Somehow the way Modo-Me set up the gizmo was blocking the individual move, rotate and scale gizmos. I missed couple API updates. The gizmo part was influx back then so I hardcoded some defaults. This is resolved now.

Also you can now use the Transform Orientations in the header bar properly too.

I will make a new release in couple days.

1 Like