Mouselook Navigation addon (+ZBrush mode)

Yes like in Object mode i want it to behave like Blender’s normal navigation behavior, i dont want it to use left mouse to rotate view and trackball mode for navigation, I have to turn off 2 icons of the plugin, and the button in the add-on option in preferences cant remap.

I too disable Mouselook Navigation when in object mode. I am not sure how it was working, or if it was because it was an older version of the add-on, but at one point when I switch to the Sculpting tab the add-on was active, then when I switched back to the Layout tab it deactivated. It was so nice. But now I can’t seem to get that functionality to work anymore.

buikrin, I’ll try to add “auto-trackball” feature in the next release.

Jaidek, it is possible to limit the addon’s keymaps to specific object modes:
image
(You will also likely need to click the Update Keymaps button and save Blender preferences afterwards)

1 Like

hey guys :slight_smile:

is it possible use the “press alt - release alt - zoom” method when being with the mouse over an object like in zbrush somehow?
currently i have to hover with the mouse over an empty area to make zoom work.

Hmm… try this preset: ZBrush+AltRelease.preset (8.6 KB)

The new version of the addon (1.4.0) with “auto-trackball” feature is published :slight_smile:
image
To use it, enable the “Auto Trackball” toggle and in the drop-down menu choose the object modes where you want to use trackball.

1 Like

many thanks, dairin0d but i cannot get this to work.
if my cursor is over a mesh zoom doesn’t work

Huh, strange… it works for me. I move mouse over a mesh, then press and release Alt, and after that I can zoom. :thinking:

weird, what shortcut do you use for sculpting the mesh inward?
because i have it set to alt-lmb like in zbrush … maybe thats why

I don’t really sculpt :sweat_smile: But, by default, sculpting inward seems to be Ctrl+LMB.
In the “ZBrush+AltRelease.preset” preset I provided, zoom activates when you release Alt key (but only if you’re not in some other modal operator, like sculpting). So if you use Alt+LMB to sculpt inward, you would need to finish the sculpting stroke first, then release Alt.

not sure i get what you mean :joy:

is the following possible:

alt-LMB - sculpt inward
alt-MMB-releaseMMB - zoom anywhere

Ah, so that’s what you meant! :rofl: I never worked with ZBrush myself, so your request for “press alt - release alt - zoom” was bound to be misunderstood by me :wink:
Okay, try this: ZBrush+MMBRelease.preset (8.6 KB)

i’m so sorry but it still doesn’t work when hovering over a mesh for some reason

this is how i have set it

Could there be any reason why having this add-on causes Blender death when the scripts are refreshed (F8) ?

Disabling the add-on gets rid of that hard crash. Not saying caused by this add-on but so far I have tracked down to it.

I have v1.2.6


0x00007FFEE4510000                      vode.cp37-win_amd64.pyd  
0x00007FFEE4120000                      _dop.cp37-win_amd64.pyd  
0x00007FFF099F0000                      lsoda.cp37-win_amd64.pyd  
0x00007FFEDA240000                      _sosfilt.cp37-win_amd64.pyd  
0x00007FFF09900000                      _spectral.cp37-win_amd64.pyd  
0x00007FFED9C80000                      _stats.cp37-win_amd64.pyd  
0x00007FFED9A40000                      cython_special.cp37-win_amd64.pyd  
0x00007FFF097B0000                      statlib.cp37-win_amd64.pyd  
0x00007FFF07D90000                      mvn.cp37-win_amd64.pyd  
0x00007FFEDA200000                      _peak_finding_utils.cp37-win_amd64.pyd  
0x00007FFED9A10000                      _pnpoly.cp37-win_amd64.pyd  
0x00007FFEDB4D0000                      _ccomp.cp37-win_amd64.pyd  
 
# Python backtrace
  File "C:\Users\USER\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\mouselook_navigation\dairin0d\bpy_inspect.py", line 302 in serialize
  File "C:\Users\USER\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\mouselook_navigation\dairin0d\utils_userinput.py", line 271 in serialize
  File "C:\Users\USER\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\mouselook_navigation\dairin0d\utils_userinput.py", line 316 in <listcomp>
  File "C:\Users\USER\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\mouselook_navigation\dairin0d\utils_userinput.py", line 316 in insert
  File "C:\Users\USER\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\mouselook_navigation\__init__.py", line 1237 in update_keymaps
  File "C:\Users\USER\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\mouselook_navigation\__init__.py", line 1655 in register
  File "C:\blender\2.91\scripts\modules\addon_utils.py", line 382 in enable
  File "C:\blender\2.91\scripts\modules\addon_utils.py", line 482 in reset_all
  File "C:\blender\2.91\scripts\modules\bpy\utils\__init__.py", line 282 in load_scripts
  File "<string>", line 2 in fn

kkar, thanks. The crash seems to happen when I try to access OperatorProperties of certain keymap items after the script reload, but I’m not sure yet how to fix or work around it. Hopefully I’ll figure out some solution :slight_smile:

1 Like

I just downloaded mouseLook 1.40 for 2.91 and for whatever reason the snap to orthographic doesn’t seems to work out of the box as it used to for older versions. It seems to behave as the default blender snap when holding down alt and rotating. Even when changing the subdivisions of the snap nothing changes. Is there something obvious I might be doing wrong ?

Thanks!

Nicholas_Hodgson, thanks for letting me know! This turned out to be a bug, I’ll try to fix it soon. (When the addon is enabled, it tries to detect the current keymap for 3d view rotation, but I forgot to take into account the possibility of multiple keymaps. And in Blender 2.91 the order of 3d view rotation keymaps has changed.)
In the meantime, you can circumvent it either by loading any preset (you probably want the Blender preset), or by manually changing MOUSEROTATE to Middle Mouse (don’t forget to click the Update Keymaps button after that).
image

kkar, Nicholas_Hodgson,
I fixed the crash on scripts reload and the default keymap detection. The new version is 1.4.1, it should be uploaded by now.

2 Likes