New System, and Blender hardly works

I have fought with this new computer for four months now, thinking it was something just with blender and it has not cleared up, so now I am thinking it’s something with my computer.

I have a new tower, running windows 10, with 2 NVIDIA RTX 2080 cards on it. I am now beginning to understand that support is apparently limited for RTX cards, but as near as I can tell, no one is having the problems I am having.

Blender 2.79 will open my scenes, but is so slow and laggy, constantly crashing and not responding.

Blender 2.8 will not open at all. The System console window comes up then I get the following:


So it’s giving me an error indicating that Blender must have a system capable of running open GL 3.3 and will now close because I don’t. Even though I do.

I can use the system for rendering, but not modeling. My pipeline has become that I must model on my old computer, which has an NVIDI 1060 and opens all my files in either 2.79 or 2.8 just fine. Then I move them to the other computer to render BUT…

Before I move them over, I have to reduce blender to a single open panel/window, and that window MUST be the properties panel. Then when I open the file (on 2.79 only, because 2.8 won’t open) on the new computer, I can change the save directory (slowly, because it still lags horribly) then hit render. Then it chews through my scene like there is no tomorrow and everything is great, until I get to the next scene.

So to try to solve this issue, I have updated my graphics driver to the most current stable driver from just a couple weeks ago.

I am using a nightly build of 2.79 just downloaded today, 2.79 still lags.

Downloaded the most recent, daily build of 2.8, and it does not open.

So, can anybody tell me what I am missing/doing wrong that this brand new super fast computer is having such difficulty with Blender?

Let me know what additional info you need!

Those cards are not supported afaik, ask on devtalk

what’s “devtalk”?

Also this thread says this:

All 2.80 and 2.79 experimental builds for the last five months or so have included a version of Cycles that supports the 20x0 Nvidia cards for GPU accelerated rendering.

So at the least, I should apparently be able to actually open Blender 2.8. I can’t even do that.

I can’t add much in the way of hardware support, but I too built a new PC a few months back with Win10 and 2 x RTX 2080Tis, and I can confirm they do operate in Blender.

I have had my fair share of BSoDs and Blender crashes but mostly things are OK.
(Seemed to happen when I relocated the PC but then stabalised and “went away”…)

I can only state the obvious things like

update drivers.
Is the problem only Blender or do other programs fail?
Run memtest
Strip back the hardware - how does it perform with 1 x GPU? Or unplug some DRAM?

I used to get BSoDs with programs other than Blender. In fact I do not think Blender ever BSoD’d on me!

And 2.79 and 2.80 both run OK.

BR
JN

Thank you for confirming that both should be running fine. It’s frustrating to know there is something wrong with the system.

Can I ask you, is 2.79 the oldest version of blender you installed on this computer? I had a problem once on an older system and I remember solving it by installing 2.49, then 2.5, and walking up every other official release until the current one. So if you had an older version installed before 2.79, I may try that again.

To answer your question, the only other program I actually run on this system is Firefox, and it has no issues. I have never had a BSoD that I know of, and once bBlender 2.79 is open I don’t think it has ever had a crash.

Blender’s UI and non-rendering activity aren’t really that ware of what graphics hardware you’re using as it uses OpenGL as the interface. Any 2.7 or 2.80 beta ought to work fine with any modern video card in that respect. AFAIK, there were no changes made to support Eevee or the Blender UI in general on the 20x0 Nvidia cards, and many people are using those cards today without any issues.

For Rendering in CUDA mode, the CUDA kernels come pre-built, and so to render on a 20x0 Nvidia card with Cycles in CUDA accelerated mode, you need a version of Blender that includes the newer 7.x kernels, and that would be any 2.80 beta in the last few months, or a 2.79 experimental nightly build from the same time period. Old 2.79b will not support the 20x0 Nvidia cards in Cycles CUDA mode just because the kernels aren’t there.

Your video cards are completely supported other than that.

So your system must have some fundamental hardware or OS issue, or you have some other piece of software installed which is monopolizing the GPU and making it unavailable for Blender to use. Have you got anything weird installed? Things like BIOS configuration, physical card installation (PCI setup), power supply connections, or even a wonky power supply could possibly be responsible.

The first thing I would try would be to pull out one of the 2080 cards and see if it works better with just one of them (if it doesn’t, then try the other single card).

The only software I am running that is not stock to windows 10 is Blender and Firefox. Even on Windows 10, I uninstalled all of the games and unnecessary stuff windows likes to install, so this system is deliberately running lean. The purpose of this tower is just rendering, so I have not installed ANYTHING extra on it.

The information about the software components is helpful. As the issue I am having appears to be UI related, I assume this must be an Open GL issue. By the way, I have tried a common suggestion I have seen to play around with the “Windows Draw Method.” None of the methods seem to behave any better or worse than the default settings.

I should mention that yesterdays Build of 2.79 is not as slow as the previous version of 2.79, which I believe was from early May.

I have removed the first of the 2 cards. The result is no change. 2.79 is very laggy, and if I try to change the selected object in 3d view window, Blender locks up and never seems to recover, even after 15 minutes. 2.8 still gives the same errors listed above.

I am about to switch the cards. Have made the switch, and am running the test again. Same results as the other card.

End result, Card A, Card B, Or Both Cards, Blender 2.79 lags, and 2.8 fails to open at all.

Everything else on this computer is default, I have no modifications to the drivers, applications for the cards or bios or the power management.

I use both Blender 2.79 and 2.8 with RTX 2080 Ti’s cards every day, and I can confirm that it works like a charm.
But I remember that the first time it was VERY, VERY laggy.

After

  • Updating the GPU drivers
  • Going from CUDA 9 to CUDA 10
    Every thing was solved.

See you :slight_smile: ++
Tricotou

how do I change Cuda versions, or for that matter, how do I tell what version I am using?

It depends on your OS. I run Ubuntu 18.04


On the official Nvidia Cuda download page you can choose your system settings before downloading a custom installation binary

1 Like

I installed the toolkit, and can only assume I am on the most current version of CUDA. Unfortunately, nothing has changed. 2.8 fails to load, and 2.79 is just as laggy as before.

CUDA is included in the driver so you only need to install the toolkit if you’re going to compile Blender from source code. Currently the beta builds are built with CUDA 10.1

Rats, was hoping that might work. I was already up to date then.

Have you looked at the Performance tab in Windows Task Manager? Do you see any load on the CPU or GPU when the system is idle? When Blender is running but idle?

If you find the blender.exe program file and right click on it, is there a “Run with graphics processor >” or “Render OpenGL on >” option? Just to make sure Blender is actually starting up on the card you think it is (rather than Intel integrated graphics say).

Do this to see what’s going on.
Go to the folder where blender.exe resides and open a Power Shell there by selecting the folder and holding Shift and right click on it.

If blender crashes you see the error. Hopefully someone will help you or google the error.

When Blender is open but idle, CPU is at 0 Percent, and the GPUs are at 3-1% and 0%.

I don’t think this motherboard has integrated Graphics at all. (There is no graphics ports on the motherboard, only on the GPU’s) when I right click I get the option “Render OpenGL On>” and then the choice of GPU’s when I click it. The NVIDIA Control Panel already has Blender set to the global settings (All) for CUDA GPU’s, so I have left that setting alone, not wanting to upset things.

If you have both cards in, make sure you try both options under Render OpenGL on > just for completeness.

You don’t have them set up in SLI presumably?

This gives the same errors that are in the system console window I posted in my original screenshot. (plus the pop-up window announcing the closing of blender.)

Have you tried getting the latest builds from https://builder.blender.org/download/.
Cuda 10 support was added only a few months ago.

If SLI means linked together with the cable, then no, I do not. I have tried Render OpenGL on card 1, but have to run an errand and will not be able to try card 2 for an hour. So far no change.