Offset Edges

is there a new fixed version of this? Mine stopped working several days ago :frowning:

It’s in this addon: Mesh edit tools 2.8
soon to be added back to release.

3 Likes

Can we also have a standalone of this just like in Blender 2.79b ? Thanks.

Hi. What part do you miss about it being standalone?
With this included in Mesh Edit Tools you still have access to it from the Edge menu. Also access from N panel and if you want you can add it to Quick favorites.

By the way, as a personal opinion I think that Loop Tools and Mesh Edit Tools are addons that make the work for modeling much easier. They should be enabled by default in Blender. There are no reasons to make new users suffer when they face challenges that with any of these two addons could be quickly solved. So they must first suffer, hit their heads against the wall until they ask in a forum and someone recommends these addons.

1 Like

Hello @YAFU, the reason I want that is I am current “struggling” to move to 2.8, it is painful as it is enough, I just want feature pairity with my 2.79b add-ons, I have already stop learning anymore more add-ons until my existing 2.79b add-ons gets ported to 2.8.

This add-on was added into my 2.79b as just simply edge offset, I actually use it for my FUI [Fantasy User Interface] creations [base outline around meshes, think Ironman Interface], I just want this ported as it is, a single addon…for 2.8, I don’t want to make the port any more messy as it is.

I don’t want this plus a whole bunch of “stuff” I am to be told is to be good for me.

I don’t know if this is possible…let’s hope the creator of this add on will create the same exact script for 2.8 as he has for 2.79b without the other bells in it. Just Offset Edges, operating JUST like in 2.79b.

I still have these add-on to move before I can go to 2.8:
camera-calibration-pvr.py
create_image_plane.py
DestructiveExtrude.py
Light-Cannon-master
mesh_offset_edges_0_2_6
Object_Shake.py
space_view3d_bmax.py
Wonder_Mesh-1_0
3D View: Stored Views
Tile

If these add-on don’t move, I am afraid I will be stuck in 2.79b for a long time.

Have you tried if this still works?


Or has it lost compatibility due to a recent change in API?

weird it works fine for me in latest build what is the problem?

hi, just a note that most all the addons in mesh tools are standalone too. It’s designed it that way. multi extrude and face inset fillet are ‘built in to the init’ for the moment, the rest are not.
@bracer

If these add-on don’t move, I am afraid I will be stuck in 2.79b for a long time.

That’s not a great way to look a things, Addons will take time to be repaired.

I don’t want this plus a whole bunch of “stuff” I am to be told is to be good for me.

Mesh extra tools was in 2.79 release and included offset edges, it’s coupled with some of the best and most useful mesh tools written over many years with no real counterparts built in, which is why offset edges is included. I don’t want to lose Offset edges either. Where better to put than in Blender with it’s sister scripts.

2 Likes

What a fantastic addon!!! I wasn’t aware of it. Thank you!!!

@Meta-Androcto
In 2.79, Offset Edges had a modal mode where I could move my mouse left and right to change the Width. It’s not the case in 2.8. Could you look into that?

Here’s a working 2.80 version of original addon.

3 Likes

Love having the standalone option considering the modal option, but how would I alter the code to make it compatible with mesh tools. I would like to have both active, since mesh tools have other tools I like. I suppose the issue is using the same operator name?

1 Like

Yep, they have the same operator name, so just rename one of them. If you need help, just ask me.

Well, is the operator name set in bl_info or somewhere else in code? I´m a bit of a dummy when it comes to Python :stuck_out_tongue:

I’m doing it now.

1 Like

Done. New name of the addon is Hidesato Offset Edges.

Hmm, that´s weird, interactive offset move is not working for me anymore. Installed the older version again and then it works again.

  1. Is it just Offset Move , the others work?
  2. Look for any errors in the console.

I’ll update my Blender to the latest version and see…

I updated to the latest version, everything works on my side.

It is not working here. I have downloaded the latest beta of 2.8 but whenever try to install the add-on there happens nothing.