Physical Starlight and Atmosphere Addon for 2.9 (v1.4) - now with Clouds!

Does anybody know how to add fog to a scene?
I’m using the latest beta 1.4.2.

Under the Object Fog panel, I click on Apply, and it says Fog Applied to 4/4 materials, but I don’t see much happening in the viewport.
I also increased the End value for the Volumetrics (Eevee settings), but still no luck. I tried in both Cycles, and Eevee.

The Volume in the world settings doesn’t have anything connected to it, so I guess the fog is not working at the moment?

Its def not out on gumroad here

Sorry! It should be up right now. Tomorrow morning will double-check everything.

Hi @phoe-nix-art ,
Try playing with
Atmosphere > Density
Artistic Controls > Distance Scalar
controls. This is how I simulate fog to test out if material fog is working (@martinsh will be able to tell much more about how fog works and hopefully one day will write an article about it :slight_smile: ). This fills up the space with fog, but does not apply it to the objects. Whenever fog is applied to material (via Object Fog section) - each material gets its own fog node attached which simulates fog for this object.

before:


after:

Thank you @karlis.upitis

I tried playing with those settings. I guess what I’m looking for is not doable (yet?)
Something like this
image

I am planning to add a separate mist layer in later release, but for now try lowering the ‘Scale Height’ value to get foggy/misty morning shots. Value from 200-1000 should do the trick.

3 Likes

With these clouds it would be super cool to have pressure slider from current high pressure to really low flat plane sagging clouds

Then as general slider feedback, artistic control - distance scalar usable scale is 0-50 while the slider goes all the way to 500, and same for new cloud thickness that I find it going 0.1 ballpark while the slider goes to 10

1 Like

First of all I absolutely love the addon - great work!

I wanted to report that with this latest version (v1.42 Beta) I’m having the complete overexposure issue when using the “Use Real World Physical Values” checkbox. I use the photographer addon as well and changing the exposure values on the camera didn’t fix it. My GPU is a GeForce GTX 1070, I’m using Driver version 457.51. My CPU is a Ryzen 7 3800X EDIT: The workaround with changing the angular diameter doesn’t work in Eeevee or Cycles. My Blender version is 2.92.0

I’m going to check if I’m running the latest drivers in case that might be causing the issue. I’ll also update Blender if that doesn’t work. Would you like me to submit a bug report somewhere?

EDIT: Nvidia Driver version 471.96 didn’t fix it, neither did upgrading to Blender 2.93.3. Non-physical values are working fine, but for at least one scene I was counting on the physically-correct values.

1 Like

I’m amazed by the all the options this add-on provides! You did a really great job!!

However, I’m still unable to figure out a setting which works for a clean cosmic blue night sky with a lot of stars visible, the sun completely set and no clouds. Does anyone found settings which catter for it?

The settings you could play with are:

  1. Sun elevation
  2. Atmosphere: lower Density (to get a clear sky), and lower Scale Height + Intensity (to add more contrast)
  3. Stars: try increasing Radiance
  4. Turn off Clouds
  5. Artistic Controls: lower Distance Scalar, higher Falloff (they both affect the horizon)

Here’s a rough test:

You can still get brighter stars, but I would probably play in post at that point. When I tried increasing the brightness in Blender, the result was unnatural, kind of over sharpened.

3 Likes

Hey, I’m really impressed how you’ve improved the performance on the new release, I love it!
I have a suggestion for further clouds development since right now there’s not much you can play with. A really great addition would be a possibility to add multiple cloud layers on different height levels. Only this little change would give so much more variation to renders already I think. Either way, the clouds look amazing already and I can’t wait to see more upcoming updates!

1 Like