Rasterizer very high 70 to 90% causing lags

On init levels of my game every time Rasterizer very high 70 to 90% causing lags to 15 or 20 fps wtih stop where have cycles bake materials using GTX-1050 graphics card with 8gygas DDR3 Memory on AMD A-10 Quad core 4ghz clock.

The game levels init every time with lags after 10 seconds working better and lags disapear working every time with vsync on on 60fps
-Textures of materials 70% is 2048x2048
30% is 1024x1024
-My scene have 15000 faces total
-Using Camera Distance 50.00
-Using Mist working with camera distance property
-Using Cube Ocluder for not render out of cube.

If possible post here solution

Post your blend I think it will greatly help.

(if its not rendering geometry that is the problem, it could be heavy logic happening in pre/post draw callbacks, but not relevant if you don’t use it)

Also its just at init time that you have the problems ?

My blend file is very strong 200mb. All my layers have objects and dinamics objects with animations.this objectcs not in use can increase rasterizer in no active layer?

No idea. Are you spawning a lot of objects dynamically ?

I am not sure, but are occluder supposed to have a camera inside them* ?

typically they are used as dividers between dense geometry areas.

how many and what type of lamps are you using?

how many materials per object?
(each material on a object makes it drawn again*)

what gpu / cpu?

if you move all your static geometry onto a single large uv atlas, you can use render call batching which can be a huge boost if you have many objects in the scene.

geometry instancing is also nice for things under 128 vertex

Yes in on layer inactive stay all enemies 10 more 2 ragdolls

Hey bluep yes the Camera in the ocluder cube when i, m out off cube ocluder rasterizer decrease to 20 or 30% limit accpetable i go try remove this cube and made 6 planes i think with camera player out can help rasterizer to degree.
I, m using graphics card gforce 1050ti zotac 4gb
CPU AMD A-10 7860K in turbo mode 4ghz quad core and 8gygas DDR3 HYPERX FURY with win 7 64 bits.blender 2.79

are your set ragdolls to invisible? (so they don’t cost any rendering?)

armature skins typically cost animation time, so suspended invisible objects should not take up resources*

Alpha transparency, Lamps, Dense geometry etc effect rasterizier

do you have any text object with a scale of not 1,1,1?

I remember a bug with scaled text objects*

also any 2d filters?

No 2D filters, using total 11 lamps
More lightplayer a litle used.
About text need check have a lot in hud starting in hud addoverlay logic bricks scene.
Alphatransparency have a lot.

A just select materials cache in render put off vsync

Frames go to 160 but when started lag to 15 20 small seconds around 3 seconds.i reduce frame rate animations to 30 may be 24 better. Working better.

Can you send a small example for create texture with light maps? Then i can remove 8 lamps may will help a lot

My god all my text in hud scene not in 1,1,1

Rasterizer performance issues comes from … load on the rasterizer. So to optimize it, you must understand what the rasterizer does.

In short: the rasterizer talks to the GPU and tells it what to do.
This includes things like:

  • Transversing the scene tree to update parent/child relationships
  • Sending object transforms to the GPU
  • Ensuring the GPU is rendering the right material on the right object
  • Calculate what objects are behind occluder objects and don’t need to be drawn
  • Compute what LOD level an object is at.

You may notice something about all of these:

  • They all involve iteration through the number of objects.

As a result, to improve the performance of the rasterizer, the easiest way is to decrease the number of objects in the scene. You could also try removing the occluder objects to see if it increases performance by switching the CPU load into GPU load. (Occluders decrease the work on the GPU but increase it on the slighly on the CPU). If you have LOD you could also try turning it off. Just like occluders, LOD swiches GPU load for rasterizer time.

The “bug” with “scaled text objects” is when you are animating/changing the scales in real-time, which is incredibly slow (as in 5FPS slow). Other than that, text scale shouldn’t make a difference.

Yes i have ocluder cube dont using lod if ocluder is good for gpu and bad for cpu my cpu is poor when work gforce gtx 1050ti i go made a test and will tell you

I increased framerate once but disabling and removing all occluder objects…not joking…

it works well on few objects with higher poly counts…
it works poorly on a large amount of objects with med polycounts(700 - 3k)…

this is true in my tests anyway.

For me plane ocluder around map working better for frames with vsync off with ocluders working in 130 160 fps rasterizer 50%
With no ocluders rasterizer 50% and frames 110-140

With vsync on is terrible for rasterizer in my game.
Rasterizer work at 70-90%

Strange have a leg only first time start P after if player dead go to scene game over then i press restart go to menu scene i click new game then load and no have more legs. May be a cache problem?

I thinking payng price for use textures in 2048x2048 for maps and many objects.

I think in i5 and i7 processors will work better.

so it is only at the very beginning of game start?..I was unclear if that was the case earlier…if so then…it’s more than likely texture related or dynamic loading…any swapping of assets at runtime or loading textures etc…

it is probably not you CPU, it’s possible but more than likely your ram or vram…just a guess though. I also have no idea what assets you have in your scene or how many objects are running a ‘setup’ script…what the logic is doing etc etc etc…

you should not just throw a whole bunch of stuff together at once and then have an issue…start your scenes smaller and then add to them slowly…this will make your bottlenecks more apparent.

I discover make invisible objects with more of 500 faces descrease rasterizer and stay better performance using small script.

I have 12 lamps around map of level 2 will create a individual small script activate by near sensor.This will made on/off effect to light when player distance checked true or false.i think will get a bit more performance to CPU and to bge.

I made a lot of things and no sucess with stand alone fullscreen mode :frowning:
My settings:
1-2D filters: not used
2-Ragdoll physics: start with suspendDynamics and mesh invisible
3- using Mist: yes
4-Camera distance: set to 50.00
5-Point Lights: started with energy 0.00
6-Objects with 500+ faces: started invisible and visible if player distance < 30:00 by near sensor pyhon script
7-Textures: baking in render mode with shadows, AO All 2048x2048
8-Aplha Materials: using for blood effects and fire effects.
9-Shadows: disable in render properties
10-Shaders: disable in render properties
11-Environment Lighting: disable in render properties
12-Occlusion Culling*: if unset the arm of player go invisible cause the playrig scale not 1,1,1 and dont work good if apply scale dont know why *
13-Total faces:15000 sum of all scenes

After with all this changes beleive rasterizer working around 30 to 50 and first time game started have secs lags with rasterizer around 80 90

in upbge lamps with zero energy cost nothing. but not BFBge*

shadows use lots of rasterizer

don’t use percent to measure usage speak in .ms

Shadows can kill the frame rate…

In render properties i disable shadows and not have any increment in performance to rasterizer