Remove overlapping Geometry created from converting particle spheres to mesh

I’ve been searching around but have yet to find a solution, basically I have a load of icospheres scattered on the surface of a torus, and I’ve converted them to mesh. I want to remove all of the overlapping geometry inside so I am just left with the outer surface.

So far I have used face->Intersect(knife) to create the edges where they intersect, and then remove doubles, but I can’t figure out how to select all the now unwanted vertices inside the object.

Any ideas anyone?

This is how I do it but it doesn’t always work. After using the knife tool and the intersecting edges are highlighted deselect everything, switch to face select, select a few faces using the C button, CTRL+L to select linked faces, if not all visible faces are highlighted then select the faces from those areas, CTRL+L again and do that until all faces are highlighted. Don’t do that using the Wireframe view or you’ll end up selecting the interior faces. Once you have that invert your selection and all that should be left is the interior faces. I grab those, pull them out of the model to verify that it did in fact work, then delete them. After that remove the doubles and now you should have a manifold mesh with no interior parts.

Crap, it didn’t put them in order but I think you’ll get the idea based on my earlier description.

Hi, I’d go back some steps and just:

  1. Shift Ctrl A to Make Duplicates Real (in Object Mode, for those who haven’t yet).
  2. Select just the former Particles / newly real Objects and Join them into a single Object via Ctrl J.
  3. Add a Boolean Modifer to those / it, set it to Union, select the Torus via the Modifiers dropdown, then Apply it.
  4. The Object you select in the Modifier dropdown will be left over and causing shading errors (Z fighting), delete or hide it.


Nice solution! I do often get left with shading errors using my method but have not found a solution to that problem, usually I just don’t worry about it as I’m not rendering for ultimate realism.

Cheers guys, my mesh is a lot more chaotic than your examples but I’m giving it a go!

Well after seeing your model this is where my method might fail? Keep us posted, I’d like to see what solution works for you!

Looking at your pic I think my method as posted will fail too. For such a case:

  1. I’d script booleaning the particles together and the cleanup, or
  2. Try an automated retopology such as via a Shrinkwrap Modifier and another Torus.

Also encountered in recent travels

Edit: As per the Bool Tool addon and its particular Union via Shift Ctrl Numpad+ should deal with the above. Can take a minute and might need to Remove Doubles in Edit Mode.

1 Like

Another option is to use a metaball as the particle object instead of a mesh sphere. No extra boolean steps needed as they are automatically merged together. You can either keep it as a live particle system, or convert it to a static mesh.

The BoolTools addon is doing exactly what I want it to, had to hop back into 2.79 in order to use it but that’s par for the course at the moment, cheers!

In the future, its a good idea to include an image in your original post, as one problem may have many solutions depending on the context.
Also a quick description of why you want to do the thing that you’re doing also helps a lot.

1 Like

Sure thing. I was attempting the painterly style clouds as seen in ‘Paths of Hate’ :

No probs but @cgCody’s method looks like it’ll work in 2.8 and is probably the quickest and cleanest for such structures. Internal shells are still possible but should be easier to pick and delete.

Cool looks / BHTS, plus the tutorial at around 20 minutes in. Lost some Blender centric notes I’ve yet to test about that method. Please post some results, steps or a timelapse if you do.


Sure thing, so far I’ve scattered a load of icospheres over a torus, used the boolTool addon to get rid of the internal faces, UV unwrapped it and baked out a texture to it. I have a cloud sprite made with a material setup which takes the vertex colors of the parent mesh, but I’m currently having no luck in backing the texture from the UV to the vertex colors. This is in 2.79.

Seen or tried this?

Pretty sure there was another older addon for texture <> vertex color transfers. Wonder what the Data Transfer modifier hides too. Failing that, try Meshlab.

There’s an addon that can be enabled from the preferences, but it doesn’t seem to work, or at least i couldn’t get it to… I’ll look at the one above, thanks!

Thanks LoboTommy. I tried. At least someone noticed the effort. :wink: