Rotate with active target problem

Hello everyone,

I am a Blender user since version 2.66 and I remember having always used, until a few versions ago, the rotation technique with active target mode around the 3d cursor as pivot in edit mode.
There is no way I can get it to work like I always have, it responds differently every time…

I have not found any news about the subject anyware on the web, can you help me please?

There is «center view to cursor» in the view-align view menu. I do not think you can set this to be permanent but you can assign a hotkey for it.

Hi DNormn and thanks for the replay.

It doesn’t seem to make a difference, “center view to cursor” only align the center of the frame on the 3d cursor, then the behavior is the same as before…

It is probably because of your navigation preferences take a look at this thread which is a similar problem,
note the preferences that I post near the end.

Ok, thanks again, I’ll try to understand something…
which thread? :slight_smile:

Sorry I did not link it!
this one

Nothing to do, it doesn’t work… but maybe I was unclear in the explenation…
Look at this:

The active vertex is in the opposite position with respect to the target and if I repeat the operation on the same vertex it changes again randomly…

Yes, sorry I misunderstood your question.
Edit:
Ok I think I know what you mean now maybe this

Yes, I was uploading the same screenshot…

I’ve tried them all without any result…
Thanks for your cooperation so far, you are great!

Mmmm, it is not a feature I have used but after playing around with it it does seem to give erratic results, maybe you have found a bug!!!

I have just found this https://developer.blender.org/T59104 it has been happening for a long time, it is marked as solved but if you read the last commit it says only solved partially :frowning:
Edit: that bug was not exactly the same but seems related. I have been playing around with many settings and can not get it to work as expected.
Maybe you should report it as a new bug request.

Ok, I’ll do it! In he meantime thanks a lot for your support!!
See you!

Maybe we are expecting something that is not really supposed to work this way.

I would expect that in edit mode it would rotate the active vertex in your screenshot example to «point» to the vertex you select on the cube but it does not (at least not exactly sometimes it does approximate).

I think that the problem is that we are trying to align to the rotation of a vertex, not point to it. I have found a way to do do this via triangulation, using three viewpoints - front side and top. In this video I have put a flag on the end for clarity. I also extruded a vertex to the cube, just to make sure it does line up.

Was this what you are trying to achieve ? This does seem a little complicated for a simple operation!

I have to admit that I usually only use snap to move vertexes and I am not an expert, I am also learning from this question. There could be an easier way to do it.

Maybe this would be more a feature request than a bug, I do not know how this worked in 2.69 so I am not sure.

Align rotation to target is more useful to align for example an object to a slanted face as in this video:

Ok, I could easily proceed like this if only on my system it worked… I have also reset my preferences but nothing, my edge runs away in the opposite direction like in the first example I posted.
In any case in some previous version of Blender it worked at once and not so strictly view dependent…
I don’t know what to do anymore…
Thanks again!

I just noted you are using 2.92 Alpha, I was on 2.90.

I have a copy of 2.92 Alpha as well and have tried doing the same as I did before, you are right it does «flip» and act totally erratically giving different results every time. That was not happening to me with 2.90. So I think it looks definitely «Buggy», and it does not seem to be your system it seems to be Blender version related.

Sorry to have given so many unusefull answers.

At least now I fully understand what your problem is and you are not alone it happens to me in 2.92 alpha as well!

Very interesting question, I also want to know how to achieve this kind of manipulation…
Maybe ask in this thread?


Is it possible with this addon or not…

Hi APEC this question has turned out very interesting but unfortunately also frustrating. I can confirm that using the same file saved with the same options the results are totaly different and more erratic in 2.92 than in 2.90.
I have not tried the add-on but it does seem interesting I will try it out and see if it gives more predictable results.

You have been absolutely SUPER with your answers, especially this one and the information about the version you have used.
THANKS!

I have been fiddling a bit more and have found a way to get it work in 2.92. Basically the same as I was doing in the video but instead of changing viewport’s orientation, ---- after selecting the active vertex press R X (then snap to the cube), R Y (snap to the cube) and R z (snap…)
this works, it seems the the rotation snap works only one axis at a time not all three at once.

Edit I have made a new video for 2.92 :slight_smile:

This one should be the solution for 2.92 Alpha

1 Like

You are the BEST!! :sunglasses: