S.Menu adding new pie menus


(Syler) #1

i am currently in the process of making new pie menus.
if you want to download the addon you can do it here: S.Menu


  • Add Pie menu Replaces the add menu (object mode) Supports: QBlocker, Bolt Factory, A.N.T Landscape, Rock Generator, Pipe Nightmare and Extra Objects (Mesh)

  • Add Pie menu Replaces the add menu (shader editor)

  • ‘A’ Pie menu (De)Select Invert Selection and access to apply menu

  • ‘Q’ Pie menu fast access to hard ops and other stuff Supports: Hard Ops, R.Array, Box Cutter(Only a quick launch Button for bc)

(radi0n) #2

Good job! Waiting for more!

(Syler) #3

thanks for the complement i will work on a new menu tomorrow, i will finishing the add (node) menu today probably

(radi0n) #4

Can you add to object pie menu, extra curve, object and pipenightmare addon?

(Syler) #5

sure extra curve, object are going to take a while tough pipenightmare should be easy im going to look into it in a few minutes if its as easy as i think it is to add pipenightmare then i will update the addon later today or tomorrow extra objects is already on my todo list but i want to add other things first, i will add extra curves to my todo list but its going to low prio so dont expect it anytime soon.

(Syler) #6

okay so i added pipenightmare but the addon is currently broken because the devs changed cursor_location to cursor.location at least the version that i have is broken i might just fix the add on should’t be difficult

(Syler) #7

fixed version of pipenightmare.zip (6.8 KB)
new version of S_Menu.zip (115.2 KB)

(radi0n) #8

Thanks! But i dont see pipenightmar in pie menu. I activate it in smenu prefs.

(Syler) #9

maybe you missed it because the button is not called pipenightmare it should be there

(radi0n) #10

Yes i missed it! thx!

(radi0n) #11


after new update when i disable S.Menu Q menu pie and save preferences after blender restart Q menu is still active.
Thank You for the update!

(Syler) #12

oh yeah i just realized im a idiot so basically what the addon is doing: it registers new keymaps every time you restart blender and you have the option of disableling the newly created keymap, which will not disable the menu on a blender restart, at least i think thats what’s happening, i will have to find a new solution for disableling the addon menus.
thank you for pointing that out i will fix it as soon as possible.

(radi0n) #13

The solution for now is to disable shortcuts in keymap preferences and save prefs.