Scimitar Model

Hi, I’m working on a scimitar. This is actually my 5th attempt, but i think it’s perfect by now. The hilt is a separate mesh, parent to the blade, since the hilt is subsurfed and the blade isn’t. Anyway I found a cool shiny metal material but it suddenly has ugly black spots on the blade from it. I think its reflecting the hilt. If so, how do I make the hilt not be mirrored? Or what is the problem? thanks. Here a render.


Take some more renders. It might be a problem with your mesh. Could you post a wireframe?

Other than a hole it might just be the reflection like you said. If so, changing the light positions should work or tweaking the mesh.

Thanks for quick reply - Moving the hemispherical light did nothing (by the way I’m using Blender International Renderer) and I really don’t feel like tweaking the mesh as I’ve ruined a few past attemps of the scimitar that way, and only finally got it looking perfect(before materials and ray tracing). Here’s a wireframe of it some parts the edge loops look weird but thats because I was playing around with the vertices to get rid of weird dark spots/creases in renders and there not there anymore with the vertices that way. I don’t know what’s the difference between the spot with the black spot and the rest…


It looks like there are a whole bunch of edges on top of each other, that may be a problem. If you look in object mode and there are black lines on the mesh, you need to do some tweaking.

The vertices that look like they’re on top of each other are supposed to be there, the blade isn’t a flat plane, parts are extruded directly up (thats why it looks like they’re on top of each other) to give that crease running down the middle and the other near the end, then the whole thing is mirrored to the other side. And why would there only be black in that tiny spot?

did you make sure that do clipping is on and that the vertices being mirrored are fully connected to each other?

I duplicated all vertices and then used hotkey M to mirror over axis, not the modifier but it works fine. It was perfectly aligned because I used 3d cursor for scale/rotate point then snapped the cursor to one of the vertices on the edge to mirror. I had forgotten to remove doubles, I just did now but it didn’t make the black spots go away.

Hmm, I’m puzzled. I suppose a 6th attempt wouldn’t hurt!! Lmao.

In all seriousness, one test would prove if the scimitar is reflecting the handle, try a new material. If the black changes color than it is just a reflection if not then we have to delve deeper.

Yup its reflection I just changed the material to a non ray tracing one and it doesn’t have spots. So since we don’t have to delve deeper (and by the way thanks for keeping up the conversation :slight_smile: ), it leads back to a question I asked at the start, how do I make the hilt not be reflected by anything (or if possible, not that it matters that much, but instead not being reflected by the blade but by everything else)?

Maybe this page can help you out

Here is a quote from the page about max dist - “This works for both glossy and non-glossy reflections, and can have multiple uses - to prevent pulling far away objects into reflections or to fake a fresnel effect…”

I suppose that you could reduce the Max Dist considerably and the handle will not reflect. (hopefully)

hmm… the maxdist is already at default zero, i never changed it… thats weird

Sorry, I’m very new to blender, so I only know as much as the documentation tells me. Try playing around with the reflection settings. You may be able to find the solution that way. Atleast that’s how I learn! :slight_smile:

I just tried making the maxdist bigger, and, strangely, the bigger numbers turned the black into a dark gray. I’m about to experiment with huge numbers to make get rid of this, but will it affect other things when I animate with it? … yeah anyway

EDIT: Ok I put it too 100 the 10000(the limit) and it only goes to that dark gray, now lighter. And even at 10000 it only affects that same spot at the top and the line near the bottom… I’m going to try changing the color of the hilt to see if the black spot changes with it.

I made the hilt red then white and no difference, the spot is still black… Ok now i’m really confused… Help?

EDIT: Ok i just figured out i hadn’t had ray mirror on… so its not the mirror reflecting… after all that!. I changed the material to a default one and changed the grey a bit, and its fine so its a different setting on that shiny steel thats doing it…

EDIT: … Ok now when i turn ray mirror on black spot is gone… I dont remember how I thought its still there without ray mirror before… but I’ve already played with all the ray mirror’s values… HELP!

EDIT: So i turned down the ray mirror value to 0.01, but kept the ray mirror on, and its darker (cause it’s not mirroring light I guess but w/e that doesn’t matter), but the black spot is gone. It’s not so dark that it’s blending in or something, it’s not there.

EDIT: Now i turned the mirror ray value up to 0.1 and the black spot is a grey just a bit darker then evrything else. So It’s obviously the ray tracing that’s doing this but WHY?

cool…i like it :smiley:

lets seee a render

Its no different from the beginning really… here it is anyway though


I deleted the hilt and rendered, and the black spot was gone so it has to be from the hilt? but it makes no sense because when I change the hilt colour the black spot stays black…

Bump - I still need help with how to make the hilt not be reflected…someone.

It’s definately the hilt thats being reflecting, causing those black spots because when I move the hilt the black spots move to another part of the blade closer to the hilt. So now I know for sure what the problem is and the solution is making the hilt not be reflected, but I still need to know how to do that… so… post if you know please.

EDIT: After all this… I’m realizing that the blade isn’t reflecting the environment in a shiny grey tone like I had imagined… here’s an example of it reflected the blue ball… doesn’t look like shiny metal at all… Is there a way I can make the reflections B&W? Or all in some specific tone? Otherwise, After all of this, I think the blade just won’t reflect… so yeah If you know how to make the blade freflect in B&W, or, even better, In a specific tone, then please post.

EDIT: When i change the mirror colour in the material space(next to spec and Col) to a grey to tint everything that, all it does is make the whole blade darker, the blue thing reflected fro the sphere just turns to navy, no to a grey tone… I think I’m just going to give up a shiny reflecting blade unless someone comes up with how to make the reflection B&W, and knows how to make the hilt not get reflected…

EDIT: Ok no more ray tracing look at the last render (not the blue ball one) it’s the new non mirroring blade. I put the hemi light to 1.5 energy, but even that and a light grey the blade is pretty dark. I want it bright steel, not dark iron. Even if I set the colour to white the blade is still a decently dark grey… Anyone know how to make it a nice light coulour? The specular is already and 1.7 and hard and 300. Ohh nevermind while typing I just realised I can change the diffuse reflectivity to make it brighter. Ok the scimitar is officially done once I’m happy with the lightness of the grey.


Very sorry for quadruple posting but this is probably the last post so anyway, here is the final, complete, finished scimitar. I made it brighter with a diffuse reflectivity of 1 and made the grey a little brighter. I turned the hemi light back down to 1. Also on the last post the picture of the sword replaced the one I talked about in earlier edits of the post. Now time for a few more weapons, maybe a shield, then to make the actually knight, then to make a few and animate some fights!:smiley: Thats my big project and I think I can call my scimitar part of it perfect now:yes: . thanks for replying nav, cya