SketchUp Importer v0.23 released

For Blender 2.93.x LTS series is available now.
Get it from here.

  • The above link takes you to the GitHub page, where you can download the file as an addon.
  • Only Windows build available.

Release Notes

No new major feature added, only critical bug fixes.

sRGB to Linear Color Space conversion
Missing UVs on random objects

Earlier Releases :


PS: Go through a few of the guidelines “on how to file a bug” on the wiki; and always make use of this issue template, which has been provided.



Thank you. It worked without any problems. Nice work !!

This is brilliant! So over having a seperate download of 2.79, importing, saving, re-opening in 2.82. Expected this to be done by the original developer much sooner. Much appreciated!

Thanks a lot, great move.
Btw. Now we have dissolving extrude <-> SKP’s Push/Pull, still easy pivot and origin operation is needed, SKP alike.
Trimble would have to develope BL export soon :wink:

Thank you. Any chance of it being OS X / Mac compatible?

Sorry, I do not have access to Mac.

Great work. Very much appreciated.

1 Like

Thank you very much.

Arindam, dude, thank you so, so much! You have no idea how long I’ve been waiting for a version that works with 2.8x!

I tried it on 2.80, and it has worked perfectly so far!


Thank you very much, I’ve been waiting for this for a long time

1 Like

Thanks! Been waiting for this! Does it work with geometry generated with the profilebuilder plugin from SketchUp? I use this plugin in skp all the time and with the old version for 2.79 it always had bugs

Hello, I tried yesterday with this new version, and same issue happens with profile builder generated geometry… I didn’t try to explode and regroup thes geometries before importing.
Anyway, many thanks to Arindam for this loooong awaited update!

I am sorry to say that I wouldn’t be able to provide the required support with regard to any 3rd party Extension(s) you might be using on top of SketchUp (to a point I would say, even if in case it’s officially supported by Trimble).

There are multiple reasons to it, laying down a few;

First, let us have a look at the underlying structure of this Importer, it’s control, logic and data flows.

As you see, it’s not a very straightforward schema as you would find with most other Blender Addons.

The required data (geo-mesh, textures, material IDs that resides in your (.skp) files are fetched inside Blender through a ‘bridge’, and this bridge is only made possible through compilation of a bunch of Cython files. These Cython files are mapped to SketchUp’s header libraries, these are mostly Data Structures written at a low-level (what we call as DNA in Blender) and you can call the slapis as RNA, a kind of.

While when you use any extensions or plugins for SketchUp, it would be most probably written in Ruby (a high-level language). Hence, the disconnect.

Second, most of these Extensions (Plug-ins and Addons, in other application’s terms) are kind of hackish methods. Many times, these would create stash objects (it could be temporary objects but necessarily not, all of the time). This creates problems when parsing such null-objects (their stored rotational values) and such.

So, I wouldn’t necessarily call it a bug from the perspective of this Importer.

The solution at hand for you: maybe you need to clean-up your file in SketchUp itself before importing (as suggested by @Balda along with purging the unused data). You can probably use another Extension to automate and speed-up that part of the process.

My foremost goal for this Importer as of now is to have all its feature working perfectly for 2.82a which used to work in 2.79b

Only after that, I can think of improvising it further (independent of any 3rd party SketchUp extensions).


Ok I understand it’s a complex add-on, and you can’t make sure it works with every SketchUp plugin, but what I meant by saying that is that if you’re looking to debug the old/new importer, the old one had bugs with geometry that was generated through this profilebuilder add-on. I think I had it on other parts of the SketchUp model too but it was always visible with geometry generated through this plugin (so you can reproduce the bug easily). It’s regular geometry based on components or groups which are native SketchUp geometry. It just an add-on to create these faster.

The workaround to most of these bugs (profilebuilder but also other bugs) was to save the file to SketchUp 4 before importing into blender. I think the names of the components and groups changed in the SketchUp file by saving to skp 4 so that they got imported more easily in blender or something else happens when you downsave but this solved most problems. Just wanted to let you know as you’re working on this

It is working in 2.90, but it seems like it work with older generation of sketchup file; the file that area save backward in sketchup also doesn’t work. I have tested it several time. I am moving away from sketchup, I don’t like their business model; forcing or traping users.

Thanks you again for this add on.

Well, for me SKP2019 works just fine.

I have tried sketchup 2020 and save it back to 2019, it sometime work and sometime doesn’t; I don’t know why.

1 Like

There are some settings while importing, maybe try this.

All import setting are at default. But when it works, the imported objects are looking clean.

I can give you remote access to my machine if you need and want to compile for MacOS.

1 Like