Smartphone remote

Smartphone remote - Smartphone as wireless spatial controller for Blender.

This tool allows to use the smartphone as a 3D controller (only for camera for now), a free wireless spatial controller for everyone.

drawing drawing

Unstable, use it at your own risks. Currently tested on Blender 2.8x on Windows platform with android Oreo (your smartphone must be ARCore compatible !).


Source and download:

All install instructions are given in following repository


Features:

  • Camera movements and intrinsic streaming
  • Scene streaming (GLTF) in AR (ARCore)
  • Scene location and scale offset (from application)
  • Camera recording

Application quick view:


Links:

21 Likes

this is a good reason to upgrade smartphone.

Curious is it possible for it to use the postional data from the phone to control camera movement? I remember there being an initiative for 2.7x

Hi !
Yeah its one of the features :wink:
Here is a quick demo:

6 Likes

Thanks Slumber for the update. Now, droppung everything from my todo list to try this out,lol. A great deal of geniune thanks for putting in the development work. Makes me proud to be a part of the Blender Community.

1 Like

Great, I had a grand master plan to use my phone as the Blender terminal output and was not able to figure it out so that Blender is not blocked during that process. Is this blocking Blender ui interaction during the controller session? In any case i am going to try it, thanks for implementing it.

It use is own thread so it doesn’t freeze the Blender ui :wink:

1 Like

Very good, thanks

I don’t seem to be able to install the addon, followed the instructions from Gitlab, including starting blender as admin. Might be because I’m using 2.81 which is portable?

Fantastic!!! Its very useful , can it be like UE4 Remote? stream blender viewport to smartphone , not whole scene model... its very useful for virtual camera workflow

@bloox64 I’ll test it on 2.81 today :wink: Are you running it on Window 10?
@Sherlock until now it only stream scene data as gltf but viewport streaming is the next feature I’m working on !

The bug is fixed, thanks for the report !
You can try this updated version, it should work :slight_smile:

This is a huge step into using Blender for virtual film production you’re doing here.

There is an excellent talk on the subject with a hands on demo(Bladerunner 2049) from here, using a tablet set up with ps controllers:

2 Likes

@slumber

any chance of including the addon updater code into your addon? https://github.com/CGCookie/blender-addon-updater

May be convenient as you add future updates,

2 Likes

It’s a very good idea !
I’ll try to do it for next release :wink:

2 Likes

Curious, is it possible to have two device with the data stream to them? One just for visualization and the.other that controls the positional data.

FYI, be great combined with multi users with blender. I believe there is a script for it.

1 Like

Until now you can have only one device per computer, I haven’t wrote the necessary code yet . But it could be done easily I think (I add it to the roadmap ) !

Another solution could be to use the multi-user add-on with the smartphone remote. By doing this way you should be able to have X users with X smartphones on the same scene :wink:

Hi, when since I tried this addon I changed computer and phone, althought none of them were the problem very probably.
I did never pass the part of pointing the phone just realized I had to pooint the phone to a plane to recognize a scene and now that I did I see I can’t request scene update or stream the camera to blender.
I have a xiaomi and I allowed blender on the window’s firewall.
Where’s the folder where the dependencies have been installed in case that’s the problem?

Hi @bloox64,
Sorry for the problems you are having with the smartphone remote setup,
Depending on your python configuration, dependencies are installed into one of these paths:

  • BlenderInstallationDirectory/2.83/python/libs/
  • BlenderInstallationDirectory/2.83/python/libs/site-packages
  • 'C:/Users/yourusername/AppData/Roaming/Python/Python37/site-packages

I added a patch to make the dependency installation more verbose and fix potential errors you encounter. Here is the latest version.

Module verbose install example:
blender_yY2vWs785B

Hi, apparently the dependencies are correctly installed. On my 2.81 instaled version it’s under the instalation directory. I also tried the 2.83 alpha and got asked once again for firewall permissions which I accepted, and still got no luck.