Smooth shading looks weird

I’m relativly new to modeling in blender. I’ve made a object with a bevel over the top, so there are a lot of edges on top. Now when I turn on smooth shading, the areas near this bevel get a edged, sharp look at certain regions. Is there something you can do to get a cleaner look?

Any help is appreciated :slight_smile:

Thanks in advance

view with smooth shading on in object mode

model in edit mode

You have tri’s, ngon’s and quads attached together. The shading happens on a polygons face with it’s edges as bounds. If there are breaks in a continous loop of edges, the smoothing will interpolate for the new topology.

For your example given:

The 2 Ngons are the cause of the big quad based shading errors. The triangle fan causes the indention on the side. Also most of the edges and quads on your upper surface have no meaning. They dont shade it better, they dont change the topology, they are just there waiting to cause problems. What you want is to have vertex or edge if something changes on your topology.

1 Like

Hi, Yes everything that Xortag said, also do you need all these loops if not you could dissolve sum of the unwanted ones in the problem area and make sure there are not any unconnected vertices.
if you can post the file, i will show you how.

1 Like

I don’t know if I really need those loops, I’ve just turned up the resultion of the bevel.
object.blend (687.7 KB)

Thanks for helping me :slight_smile:

Is there a way to avoid those from the begin of the modelling?

Because I worked a lot with the bevel tool and sometimes it creates those Ngons. After the bevel it’s really hard for me to remove them or merge them into quads.

The way to avoid them is to save beveling until the end, after you have your basic shape, after you have marked seams, after you’ve done all the extruding you plan on doing.

1 Like

Look into the wieghted normals addon.

1 Like

Yes, as a starter, do not use the bevel modifier and also try to never apply it. If you can’t guarantee for a clean topology, it will mess it and you don’t get it cleaned. Use it after everything is completed and give it more control with edges marked (Bevel weight). Remember that a Subdivision and Bevel modifier love quads, otherwise custom topology is created without your control.

Start with a flat plane and use the “Orthographic View” (Numad 5) with the appropriate front (Numpad 1), side (Numpad 3) or top (Numpad 7). Remember you can use the solidify and mirror modifier and just need to work one side. Blender will make sure anything you do will happen exactly on the other side. Do not apply modifiers if you don’t have to.

It will take some time to learn proper topology flows, so don’t let you get down and try more. It’s a good advice to stay co-planar on your transformations as long as you can.


ok I’m going to start this model again and keep an eye on the topology, with just using squares.

Should I start with extruding the plane or adding loop cuts to it?

Lots of ways to start. Personally, I’d start with a cube and flatten it to the thickness you’re looking for, but you could just as easilly start with a plane and extrude it up to the appropriate thickness. Only add loop cuts to get faces that you are planning to extrude, or to change the slope of a surface.

1 Like

so I should go for extruding the object in “2d”, until everything is like I want it to be and after adding the details and bevels?

I generally model 3D objects in 3D. I’d only do a flat outline if the outline was really complicated, like an elephant or something similar. Even with organic models, box modeling is still a good way to start.
Ok, architectural models can start with 2D floor plans, then extrude the walls up.
What kind of model are you making?

1 Like

An aircraft in general but at the moment I’m stuck with the wings, because they’re aerodynamic and the model has to have smooth elements. I’m trying to model those right now but it is very difficult to keep everything in quads.

looks like this:

I really don’t get those curves to work

edit: I just see that I’ve already messed up with the faces in the middle

Ignore details and small stuff. Just model the big shapes first and then advance. Not everything needs to be of a single mesh and can just be a floater. Remember that a subdivision Surface modifier will round a edge into a circle when the proper edges are present. Since you dont want the full wing face rounded, we need a piece of topology that account for that. That said, it just needs a big face for the wing, and a loopcut on the bottom (STRG+R). The bottom right and bottom left edges get rounded.

It is more easy to integrate and combine complex parts into big shapes, then joining complex stuff with other complex objects.

Example with “OpenSubdiv” workflow. Classic Subdiv modelling would have additional edge loops to control the sharpness of edges. Pink lines are creased.

1 Like

Ah! Hard surface modeling. You’re better off, then, getting advice from someone experienced in that, rather than an organic modeler like me. Tris and Ngons are anathema to organic modelers, but the rules may be different for hard surfaces.

1 Like

You could also model as you like, without constantly having to pay attention to keeping an all-quad-polygon flow, and buy this great auto-retopologizer (that’s how I do it these days):

1 Like

Thanks for sharing this addon.

It works really well and makes it a lot easier, but unfortunately it’s only free for the trial. For me as somebody, who works with Blender just for fun and has not much experience, paying for an addon is not the best option. When I’ll be better in modelling, shading, etc. it would be a nice tool to go with and I’ll then probably buy it.

But it’s a nice tool to keep in mind :slight_smile:

1 Like

Understandable. Well, you know about Quad Remesher now. You can start by using the free Quadriflow remesher that’s included in Blender (available since version 2.81 I believe).

1 Like

I’ve tried this out and this works better than I had thought. Didn’t knew about this feature yet, but it’s incredable useful. Thanks a lot, I think I’ve got it working correctly now. :slight_smile:

1 Like