Solutions to common problems

This is an attempt to put to gather the most common solutions to blender not running correctly.

Blender runs slowly
First, as blender uses OpenGL for it’s interface, bad OpenGL drivers will cause blender to run slowly. Try upgrading your video drivers. If your video card supports hardware accelaration, and your drivers enable opengl to use it you shouldn’t have any speed issues.

To check if you are using hardware accelerated OpenGL drivers try copying the following into a file, loading the file into a text window (with the dash button on the window header), and running with alt+[p]. The output will be on the console.
(instead of copying/pasting to file, saving, loading in blender you may download this)

from Blender.BGL import * 
print "GL Vendor  ", glGetString(GL_VENDOR) 
print "GL Renderer", glGetString(GL_RENDERER) 
print "GL Version ", glGetString(GL_VERSION) 

you would like the vendor to be the same as that of your video card. If it is Microsoft or Mesa blender may run slowly. Mesa can use hardware acceleration, but it doesn’t have to, so look at the Renderer if you are running on mesa.

for example, the Windows XP default opengl driver (the one you don’t want to use) would print

GL Vendor Microsoft Coporation
GL Renderer GDI Generic
GL Version 1.1.0

my computer, running the Nvidia drivers gets

GL Vendor NVIDIA Corporation
GL Renderer GeForce2 MX/PCI/3DNOW!
GL Version 1.2.2

This is a linux system that works quickly:

GL Vendor VA Linux Systems, Inc.
GL Renderer Mesa DRI Voodoo3 20010501 x86/MMX/3DNow!
GL Version 1.2 Mesa 3.4.2

the GL Version shouldn’t be an issue. It is also unlikely that it is below 1.1.0

and some links that may be of use
Blender3d.org Graphics Card compatibility page
blender.org: Graphics card compatibility - post your specs here! (more recent)

Other Graphic Solutions
On some systems OpenGL acceleration is very sensitive to color depth. Blender usually preforms best at 16 bit or “High color.” This can be changed in the display properties in the control panel (in windows). Sometimes blender runs better in 24 or 32 bit “High Color.”

In linux making the change is specific to your linux distribution.

Some users have reported that turning off antialiasing in their card’s advanced properties (on the settings tab of the display properties in the control panel) will fix some major graphics glitches. (Blender is kind of ghosted instead of how it should look)

Strange text in Blender 2.27 or later
On some systems the antialiased text used in Blender 2.27 or later is displayed with all of the characters on top of each other. I have experienced this in Windows 95, but it may happen on other systems. To remedy this problem turn off international fonts.

On some other systems the antialiased text in Blender 2.27 is displayed oddly in that the edges are hard in places (on one character), but in others it is antialiased fine. I have seen this on a computer with an ati card. The best solution (to make the fonts readable) is to turn off international fonts.

Pull down the info buttons from the top, and select the third tab (Language & Font) and deselect international fonts at the top left. To keep your changes put the info menu back and press control+[u] and confirm save user defaults. Do not do this when you have a file open becaue you will afterwards start with a copy of that file.

Artifacts around the cursor
I have not seen this in person, but try turning off the cursor shadow. In Windows XP or 2000 it is in the mouse properties in the control panel.
I do not know how to turn it on/off in X in linux, but it is probably specific to your distribution.

Slowly Disappearing meus
On some systems the menus and the splash screen disappear slowly. I do not know of a fix for this, but it is more of a nuisance than a fatal problem. The problem seems to lie with opengl drawing to the front buffer, and newer drivers can fix it, but they usually do not.

Blender covers up the task bar or I can’t reliably change focus to the render window using F11
By default blender will run covering the entire screen (full screened). This will cover the taskbar and may make other blender functions such as toggling the render window not work as expected, or appear not to work at all. To remedy this the shortcut to blender needs to be changed.

in windows
Right-click the shortcut, choose properties, and on the shortcut tab change the target value by adding a -w to the end. The result should look something like the following (quotes included)

“C:\Program Files\Blender Foundation\Blender-2.27\blender.exe” -w

This will make blender open in a window which solves the above problems.

Blender crashes when I select some objects
often this happens with emptys, sometimes lamps or objects with names. This usually happens on systems with intengrated (intel or via) video cards. The solution: get the latest drivers. Go to your system manufacter’s website (dell, hp, emachines…) first to see if they have special ones, otherwise (or if those don’t work) go to the manufactuer of your video chipset site for drivers.

Blender gets slower and slower, I have an ATI video card
THIS WILL PROBABLY BE FIXED IN BLENDER 2.34

it appears blender versions after 2.23 get slower and slower on ati cards with the catalyst drivers version 3.10 (or so) and later (4.5 is latest at the moment). The quick fix seems to be to use older drivers (at least for the opengl driver). There are way too many threads on this, some of which I link to here (some have detals on the quick fix, others don’t)

the blender foundation was sent 5 ati graphic cards from ati to look for a soution to this problem

http://www.elysiun.com/forum/viewtopic.php?t=24936&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=23964&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=23410&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=20840&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=24258&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=23478&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=22704&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=21891&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=21744&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=21557&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=21475&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=21441&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=19060&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=20754&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=20420&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=20260&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=20163&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=20167&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=18528&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=19631&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=18860&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=15994&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=15002&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=13361&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=11419&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=9355&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=8257&highlight=radeon
http://www.elysiun.com/forum/viewtopic.php?t=7923&highlight=radeon


I do not know of any Mac OS X problems, nor their solutions.
I hope to update this in the future as more information becomes avaliable

Cursor not getting updated (linux)

This one is specific to some Linux Distros (RedHat, for example)… when you hit Render the cursor turns into the frame count, but after the render is done the cursor doesn’t get back to it’s normal state… just park it over a Blender Window border and it will fix itself in a second or two.

Other Graphic Solutions

In all Linux distros, besides the tools the distro maker could have included, color depht can be changed by manually editing the XFree86conf file, look for a line that starts with ‘Color Depth’ into the Screens section and change the number at the end of the line… only use 8, 16, 24 or 32.

The file is located on /etc/X11/ and you will need root privileges to edit it… making a backup copy of the unedited file isn’t a bad idea in case you screw it and can’t start your X server.

Well, i normally use blender in window mode, i knew that it’s faster in 16 bit colour, ok, but sometimes buttons disappear and things were not ok at all…i have tried 16 bit and full-screen mode in 2.28-windows98 and goes perfect…my graphic Card is nVidia 128ZX, so, if anyone has the problem of the disappearing buttons in 16 bit colour mode, try to run it full-screen

I’ve noticed in the last few versions of Blender that when I try to edit my IPO curves, either Blender stops responding or the system freezes.

This is using Win98SE with a 550MHz processor and NVidia TNT 2 AGP card.

Has anyone else experienced this problem?

I had the problem of artifacts around the cursor in Redhat 9.

To disable the cursor shadow in Linux (Xserver)

echo “Xcursor.core: 1” >> ~/.Xresources

what this actually does is write a file on your home directory.
When logging in the configuration is parsed and the cursor shadow is disabled

If you want your cursor shadow back, you may remove the file and restart the Xserver

:o i have the same problem! and the same OS, and the same graphics card! i think its the graphics card, because i cant even render big pictures without blender freezing up and my computer restarting itself… ive tried all blender versions…

and on win2k its the same thing, and the pop up tells me the system recovered from a serious error because my my display drivers… i dled the drivers directly from the site, and redownloaded them to check… still them same… the only OS blender works perfectly in is winME, but i dont want to sacrifice all other functionality just to be able to render =)
nvidia tnt2 sucks bad!!! i need a new card

To Blengine & Phong,
I had similar problems, I couldn’t render or animate on most output settings. (crash)
I have NVIDIA RIVA TNT2 MODEL 64/Model64Pro
I downloaded latest driver a month ago - which was a Universal driver covering many cards.
As I remember - that didn’t cure my crashes. ? I may be wrong.
This new universal driver gives the user options to adjust some OpenGL settings.
So I adjusted - No crash - Adjusted back to default values - Still no crash.

Try the Universal driver.
It was really annoying me - now I can’t make it crash.
Cheers,
Brian

The cure wasn’t due to the new driver. :-?
Crashes on True Color ( 32 bit ).
Works fine on High Color ( 16 bit ).

I hope that Helps. :slight_smile:

Brian.

Help me!!!
I just switched video cards from a “TNT 2 Pro” to a “ATI Radeon 9200 SE” nick named “Stealth S80”. I have the above crashing problem! When I render anything it will not crash but will turn the blender interface black. And sometimes change the blender ender window to what the interface buttons look like, ie. it shows the blender buttons in the render window. I am running “Windows 98 SE” and have never had problems before.

System in a nutshell…

Windows 98 SE
did have a TNT 2 Pro
now have ATI Radeon 9200 SE called Stealth S80 on box
never had problems before I switched.

my problem:
selecting camera,lamp,lattice ( i don’t know if there are others ) blenderpublisher crash.
my system: winxp professional am2000+ 256mb ram
graphics card: s3 km400/kn400

EDIT

weird i don’t have lamp problem with tupo

EDIT

problem with lamp and camera is when you make it and save it.( i use 3 blenders 3.32,tupo,2.25 )

then some time later you get the lamp/camera problem

even weirder is that i can select the camera when i’m viewing from the camera :S but i can’t select the lamp then

I’ve tried the fixes mentioned above for blender running slowly with no luck. What’s strange is I can rotate the camera nice and smootly in a textured mode, but when I click anything, it takes forever to respond. (Lag times of up to 3 seconds) Has anyone had this specific problem?

Yeah, I got the same problem after upgrading to 2.32. Everything is fine first, but after working for some minutes blender gets slower with each command … aftter 10 minutes I have to restart and it works fine again, going through the same procedure. I don’t have the problem with 2.28, so maybe it’s a bug.

I’ve had the same problem on both versions: After some time the system lags almost to a freeze. Restarting it helps but that get’s tedious.I’ve tried changing to 16 bit color but that didn’t help. Of course this problem never occurred with my old card (Nvidia Geforce 440 MX 64mb). Now, I’m running a Radeon 9200 128mb with the latest driver, and the problem persists no matter what the display settings are. What really sucks is that I’m a beginner just getting into this software, which I like; But I’d hate to get rid of it on the count some technical bug.

Win XP Home
1500 Mghz Pentium 4
256 Ram
128 VRam
This is only a three-year-old computer; I shouldn’t have this problem. Someone please help.

@ HapeMask and XVV:

http://www.elysiun.com/forum/viewtopic.php?t=23410&highlight=ati

and search this forum for “ATI” for more enlightenment. The latest drivers don’t solve anything, in fact, they may well be the problem.

%<

Im not sure about that, as I said, I dont have the problems with the same driver in Blender .28 with my Radeon… maybe it has to do with the OpenGL code in Blender… I wouldnt shoot to fast at ATI as most people are doing.

Sweet, I rolled back to Cat 3.9 and no more problems…my pc barely runs over 15%

Newer drivers were not the answer, don’t even bother with 4.4.

actually, the drivers since 3.9 have fixed numerous bugs
(even with opengl)

but for blender, bugs were introduced (or similar, could have been a bug in blender that no other driver had shown)

Ummm… But what if I don’t want to downgrade my driver? The new Driver I got fixed some problems in the game engine, and I don’t want to use another driver :< (oh, I have an ATI all-in-wonder Radeon 8500dv)! Should I just spend $500 on a brand-new card? I don’t even have that much!

Read this: http://www.elysiun.com/forum/viewtopic.php?t=23964

Martin

Thanks, theeth!!! :smiley: :smiley: :smiley: :smiley: :smiley: