Some faces are transparent [Blender 2.8]

Hi guys. I am using latest 2.8 build. When in Modeling view, some of my faces in many different objects appear transparent. I can select the faces and everything, but they look transparent. Switching to Shading, or Layout fixes the problem but i am afraid i am missing something important in my workflow, i have been a blender user since B 2.7 and I never had this problem before…

I tried:
Adjusting Camera clipping.
Inverting normals and recalculating them.
I started a new whole object just to check if it happened again, and it did.
I am not in Wire mode and the problem persist either in edit mode or object mode.

Here is the blend:
https://drive.google.com/file/d/140Ycqd8d6ha6MAz7GIA3Gv1WkZo9RZ39/view?usp=sharing

Here some screenshots:

1 Like

Is Backface Culling checked?

Nope sir. It’s deactivated. I tried toggling it back and forth but it didn’t solve the problem.

Maybe you could share a .blend file and people can have a look at it?

Thank you John for the suggestion. Here is a blend

https://drive.google.com/file/d/140Ycqd8d6ha6MAz7GIA3Gv1WkZo9RZ39/view?usp=sharing

It’s the normals. When I flip Backface Culling on those faces “disappear”. Turn it off again and it looks OK. If you turn on the display of face normals you can see that those faces are flipped.

That part of the model is non-manifold/not watertight. Maybe that what’s causing the issue in the first place, although I was able to resolve it by selecting all faces and hitting Shift+N

Thank you Jhon for taking the time to help me.
Basically what you are saying is: to select all, Shift+N, and turn backface culling off. The normals should be pointing outside the mesh.

This is the result I am getting, normals pointing outside, and backface culling making no difference, be it on or off :frowning:

The non-manifold problem exists because I deleted faces that are never to be seen, as for example the faces touching the ground, or faces hidden by another,bigger, object. At least that is what I am getting as a result of using menu select -> Select all by trait -> non-manifold. Maybe i should start placing the faces back where they belong.

Ps: just as a side note, if I export the model to marmoset for example, it displays the model just fine, no transparent faces whatsoever

I think you might have a bug. I was looking in a build from yesterday I think. I downloaded today’s and it’s different. Yesterday’s build is showing those problematic faces as flipped. Today’s seems to be claiming they aren’t flipped but displaying them as though they are.

Just to make clear. These two screenshots are what I see when I start the relevant version of Blender and load your file. Top one is yesterdays build. Looks fine. If I turn on backface culling or display face normals I can see problematic faces. These correspond to the ones you are seeing as “bad”. In today’s build they look wrong, but backface culling is off and face normals claim to be pointing outwards. I think.

I can’t work it out. If I delete the problematic faces only and create new faces they are fine… until I assign your material to them when they disappear again.

Thank you Jhon! I am taking a lot of time from you. I feel bad for wasting your time. Its ok if you just move on to something else, but really, thanks for your time!

I tried downloading the newest Blender from today february 1st. but the problem persists. Just for the moment i will call it a day lol If i work in Shading/Layout/UV tabs, everything works just fine and since I confirmed that outside blender the faces are displayed correctly, i will leave this problem for the future. maybe its a bug, or maybe something not implemented yet. I will avoid using the layout tab while I can, lol :smile:

One last thing you could try is to Append that object (or copy and paste it) from 2.8 to 2.79. See how it looks there. Fix it if you have do and then Append it back to your 2.8 project.

Your problem appears to be similar to mine, view it here.

Just in case anyone have the same problem in the near future. The problem was caused by the material being applied to the object. Something is working wrong with the materials. I don’t know what it is but the problem persists across multiple projects, with different objects. The solution is to apply a new material to the object presenting the problem and deleting the old one.
Just for more information, the material applied was a generic one with no modifications added to it, in shading tab the material node looks just ok. I have no clue how to reproduce it.
DO you know if the problem is known by devs?

2 Likes

I don’t know if my issue is similar but I am new to Blender and can’t figure out why these textures appear transparent. From what little I know, I turned on Face Orientation and don’t know why a few are blue (correct outward facing normals) and some are red (inside facing) but everything else is not marked. I am using Blender 2.80.

Open your material settings scroll down to “viewport display” click color, look for “alpha” it could be less than 1. It’s probably a bug.

Thank you for the response. I am using LookDev mode and I click on viewport display and it appears like this.

What’s your blend mode? it’s in the settings right above. You probably have “additive” blend mode and “show backface” checkbox turned on. Default blend mode should be “Opaque”.

I did have Alpha Blend enabled and Show Backface was checked. After I unchecked Show Backface and changed it to Opaque it kinda helped but not totally.

As a side note, when I am in Solid Mode, the model textures look correct. I am concerned when I render the final that it displays as intended.

You shouldn’t even have green color in solid mode, in your previous screenshot your viewport color was white. Unless you changed shading color from material to object color. And your model is still have some transparency. Try to delete “principled BSDF” in the shader editor and add a new one so everything will be back to default. Maybe you messed up some settings.