Three Point Arch Tool (v004 and 2.80 version 012)

An update to the Three Point Arch Tool has been released, 0.1.2 (for 2.80) and 0.0.4 (for 2.7x)

The updates are on the same downloads page as usual.

This update is a bug fix to correct problems that were reported with the snapping code in 2.80, but, to play it safe, I back-ported the bug fix to the 2.79 version as well.


Hey there! this is great im loving it.

The thing is, it creates a single tab for the addon, and i want to include it in my own tab (which i made with the pie menu editor addon).

Is there a way to delete the tab “create”? Please?
Again, thank you a lot!!!

Thanks for updates

Not without editing the code (bl_category = 'Create'), but I can look into this for a future update

Doesnt work with 2.81 :frowning:

Hopefully this gets updated soon!!

Work perfect!
It would be great to have the ability to create only the first arc without further extrude, too!
Maybe with press SHIFT+Button?

ESC/Rclick before extrusion?

1 Like

Are you guys using 2.81 or 2.8? Addon doesnt load here.

When i press ESC or RClick before extrusion the first arc disappears…

Unzip the download and change the blender version to 2.81 manually. It works!

It work on 2.83 today. It will be very cool to be have an option to just draw the 2D arch, plus an option to continue with another arch just like AutoCAD does. But I am happy with what you have made. Thanks you very much.

I found the ‘Enable extrude’ Button in the addon preferences!
But when it be disabled, the arc jumps out of axis constraint!

I am not having these issues locally. I just tested installing “three_point_arch_280_v012” with 2.81a and it worked without having to make any changes to the code.

You can have the tool exit after confirming the initial arch outline if you disable the “Enable Extrude” option in the add-on’s preferences. I’m not sure what you mean by “continue with another arch” here, do you mean go immediately have the tool start placing points for a new arch after one arch is completed?

Were you using the latest version? The axis jumping was a problem in a previous version, but this should be fixed in 012. I didn’t have this issue when testing (012) in 2.81a.

I refresh my Blender 2.81a version > now it works! Thx!
Maybe you can add the enable button for extrude to the panel?
Or all of the properties? …

I made a similar feature in NP_Station - a poly tool that extrudes automatically when you close the polyline. If you would like to keep just the 2D shape simply press escape while extruding and the operator reverts to last completed phase - 2D poly. If you would like to undo the whole poly simply press esc while in the first phase or delete afterwards. I found this procedure somewhat more convenient and faster than editing an addon preference (because of constant change) or making a separate tool. It works quite nice in practice.

In AutoCAD - when I draw the first Arch and hit enter it repeat the command and continue another arch at the last point you left off; I hope the images will explain it.




Working with the latest 2.83!!! Is there any way to increase the default segments of the arch to make it more smooth?

Any chance this could be updated for the current 2.82 official release? :smiley: