Unable to select bones in pose mode (Blender 2.8)

This question has been asked a few times in various forms on stack exchange and the like, but none of the solutions work for me. I have included a short video showing the issue, where I highlight everything.

Video broken down:

  • Brand new install of 2.8 (even deleted the data in Appdata/Roaming/Blender Foundation/2.80)
  • Restriction Toggle for the armature is not disabled
  • ‘Lock Object Modes’ in Pose Mode whether On or Off doesn’t fix it
  • Unparenting the mesh from the armature and reparenting doesn’t fix it

Something I forgot to say in the video, importing that character mesh into 2.79 works and doesn’t have any of these problems (opening a saved 2.79 project in 2.80 does not fix it either). Same with other character meshes I have tested.

I genuinely don’t know what to do, and neither do my buddies who work with Blender regularly. I have been trying to fix this for 3 days now, and I am very frustrated as it’s preventing me from working with any armatures.

I was just scrolling through this forum and found this thread.

Just like this person mentions if I use the circle selection tool, I can select bones. Nothing else works.

So its not only me, some bug i guess

1 Like

did you try to change the selection key?

1 Like

Yep! I have switched it from Right to Left a few times through my tests. Even tried the other keymap presets.

image

First thing first.
Does it happen with any armature imported or made from scratch ?
What happens if you load factory setting ?

1 Like

I have no experience making armatures from scratch at the moment, unfortunately. This is happening to every armature I have imported recently. I have yet to test one that has worked, but I haven’t imported many due to my focus on getting the few I need for a current project working. I can confirm is that the person who made this character armature for me had it working fine when importing into a new scene.

As mentioned in my original post, this is happening on a completely clean 2.8 install. All factory defaults.

Edit: Additionally, I was supplied the .blend for the project from the 3D artist who made the asset and I get the same results in his file.

if you’re adding an armature - single bone to a clean scene, are you able to select it in object/edit/pose mode? If yes, edit the bone, extrude once, and try selecting the second bone.

There was in issue a while ago with older versions when only a root bone was selectable, same thing, circle select would work, nothing else.

When you say brand new install do you mean latest build?

edit - there still seems to be an open ticket - https://developer.blender.org/T65138

do you happen to use an intel graphics card?

1 Like

In Blender, that is as easy as making meshes.
Shift A -> Add armature.
Enter edit mode -> subdivide bone or duplicate it several times.
That is sufficient to test if it works well.

Unfortunately. Nobody provides a .blend file. And it was not clearly established what conditions are necessary to reproduce the bug.

1 Like

Yes, but also it’s a clean install. Previous 2.80 install deleted, including Appdata/Roaming/Blender Foundation/2.80.

This may be the issue. My main GPU ceased to function about 10 months ago, so while I have been saving for my new PC my system defaults to my on-board Intel HD Graphics 4000. So, if the open ticket is correct Intel graphics could be causing the bug somehow.

On topic, I have tested this with friends and the bug is not a part of the .blend file. I sent two friends a different .blend file with another armature causing me issues to see if they had the same problem, and they have absolutely no difficulty selecting the bones in the .blend file provided to them. Same goes with blend files sent to me with existing armatures. They work fine on their end, but I can’t select bones when I open the file.

I had a ticket about it, made a gif as well, but it seemed to fix itself after a couple of days - https://developer.blender.org/T65221

The thing is, it was easy to reproduce, but tried it on 6 other configs, didn’t have the problem anywhere else - that’s why I didn’t see a point in providing a blend file with a subdivided bone. It was intel graphics related I think, but it seems to be very inconsistent, I never had it come up since.

Hello guys.

I was having the same problem. My PC uses Intel HD Graphics 4000.
I made an addon to help us with this problem. I hope it is useful and that it helps you too.


Hello everyone,
@vfxninjaeditor In order to make the armature visible in the viewport (in all modes), you have to click on the “Viewport Overlays” icon and check “Bones” in the “objects” panel.
I hope my answer helps ! (I had the same problem).

I had the same issue on a new Macbook Pro (2019) with MacOS 10.14.6 and a Intel UHD Graphics 630 / Radeon Pro Vega 20.

The blender version is 2.80 2019-07-29, the regular release installed about a week ago with all initial settings. The .blend was created on an older machine in the 2.80 beta, but the armature causing trouble was created on the new machine.

I could only select the root bone. Circle select as suggested above worked for all bones though.

I found that checking the Viewport Overlay -> Pose Mode made it possible to select any bone with regular left click. Even after unchecking it again the bones were selectable. I also messed with the fade, but ended up leaving it back at 0.

I couldn’t reproduce this in a new .blend, but I am hoping my solution with checking the pose mode can help anybody else with the same issue.

Ive made a post too about this problem

so ive read everything here and i guess the problem occurs if youre on intel hd 4000?
cause i have the same integrated gpu too im on my laptop
i transferred the file to pc and its working fine, but i dont work with my pc
so im still finding the solution. I thought im the only one with this problem
check my post and i explained the problem even better with animated gifs
i tried reporting in blender too https://developer.blender.org/T68812