UPBGE 0.3 Alpha BlenderPlayer crashes when opening on Mac running Catalina

I downloaded 0.3. Alpha and the BlenderPlayer won’t even launch on iMac running Catalina. I’ve tried multiple times. Is this a known bug?

To go along with BlenderPlayer not launching for UPBGE 3.0 on Mac, I should mention that the Export “Save as game_runtime” gives the error message: “The player could not be found. Runtime not saved.”

Am I missing something? I am new to UPBGE.

Thanks for report. I will check it.
Maybe we need several iterations as i only have access to a development macos server where i can’t install anything.

1 Like

Thanks for all your hard work. I’ll be happy to test out or help in any other way.

I’m not sure how many other Mac users there are for UPBGE. I’d love to hear from others about their experiences with 0.3.

same problem on Linux, the last time i had Blenderplayer working on my machine where back in 2019 version 2019-11-4, it is only the standalone that is broken the main UPBGE works like a charm.

1 Like

Blenderplayer and Save as Game Engine Runtime addon is working in the last linux build now.
Tested with Open Suse.

Now working in the MacOS build

1 Like

just tested it on my debian machine and it works and thanks for fixing this :grin: :+1:

1 Like

Thank You!

The Mac .dmg file is still dated 2020-07-12 on the download page. Is there somewhere else to get the latest Mac install?

Not yet, still working on it

1 Like

I upload a new build. Export runtime fixed.
I tested launch blenderplayer from blender and export a game through “export a game engine runtime” addon. Both ways work now.

1 Like

Thanks Jorge for all your work. Unfortunately I’m getting the same errors on my end. I can send you a crash report if you are interested.

I tried on both an iMac and MacBook Pro. Both running Catalina.

Thanks again though for you efforts. :slight_smile:

Hi,

This is the way I can test in Mac.

It is a MacOS X High Sierra. I can’t move the UPBGE 0.3 Alpha folder to Applications as I don’t have admin permisions.

What do you do when you test it? Do you move it to Applications or it is similar to my procedure?
Please, pass me the crash report to get more info.

Thanks.

Hello,

I do move the entire UPBGE-0.3-Alpha folder to my applications folder. To launch I double click Blender icon, but for first opening I have to go Apple menu/system preferences/Security & Privacy and “open anyway.”

Once UPBGE is open, below is screen shot of me choosing Stand Alone Start.

And below is the screenshot of me choosing add-on export save as game runtime. ( First time I have to open from system preferences like above)

1 Like

You have a new build to test. :slight_smile:

2 Likes