Very slow GPU rendering in Cycles (opencl). Blender 2.81

Greetings!
There are problems with rendering on the GPU at 2.81, it is significantly slowed down compared to 2.79 (nightly build)
AMD RX 580 videocard

2.79 [ nightly build]
2.81 Last build

Other scenes also have a big difference in different versions of the blender.
Optimization under Opencl in 2.81 is planned?

have you tested agains 2.80? might be a bug in 2.81?

I use Vega GPU’s with 2.8 on windows 10, and have not noticed slowdowns with official build.

What driver / OS are you using?

I’ll also pull the 2.81 latest and retest on my scenes and see if I can repeat similar drop.

As for optimizations, there is one Developer that was hired with AMD Funds for that purpose, thought outside of some initial work on kernel compile times, limited improvements have been published :frowning:

Now I checked in 2.8, there as well as in 2.79

Perhaps a bug. I think it will be useful to report this
I use - AMD Adrenalin 2019 Edition 19.9.2 Recommended (WHQL) driver (Release Date
23/9/2019)
OS windows 10 build 1607. On AMD ryzen 2600

I would like to know more from the developers - are they planning to optimize as a whole for Opencl?

yeah, definitely report it.

as for the AMD sponsored developer, Jeroen Bakker did a bit of work in February when he joined, but since then, not much, just some fixes.

I hope that he’ll spend more time on OpenCL soon.

you can always write to Ton :slight_smile: sometimes he responds (or did in the past) but woudl be good to know of his plans for blender and openCL going forwards.

I hope so too

I’m shy :blush::sweat_smile:

:slight_smile:
No worries

I’ll test and reach out to him to get some feedback. Met him at one of the Blender Conferences, he is as awesome as people say he is… Just hard to understand him at times when he speaks :slight_smile:

Vega 64/win 10 user here.

Just noticed this myself - my opencl render times have roughly doubled in the latest 2.81 Beta vs 2.8 also… did you manage to flag this Grzesiek?

Would be hoping this would be going in the other direction!

Apologies, got stuck with too many other tasks. I forwared myself an email as a reminder to test this. Will prioritize that today.

Absolutely all good my man!

Happy to do it myself if you have your hands full.

Going to test the latest beta today and see if there’s any improvement… will come back with some stats later.

Be interesting to see if you have similar findings.

SO… Did some testing.

2.80 vs 2.81 (beta) vs 2.82 (alpha) Windows 10, drivers 19.2.3… (drivers downgrated after recent upgrade… darn…)

Still. just a default cube…

with nothing running in the background… results are borderline identical. 9.6s first run and 5.2s second run. 256x256 tile settings.

On larger more complex scene of my ships, there is DEFINITELY something happening…

2.80 1.58s first run 1.48 second run
2.81 2m (and only 3rd tile rendering)… More testing is needed.

I too have noticed a considerable slow down with openCl in 2.81
AMD RX 580

So i did some tests on a simple bottle render i’ve been using recently. interesting findings…

(all rendered @ 1024 samples with 32x32 tiles)

2.80 gpu + cpu (32x32 tile) - 5:26.70
2.80 cpu (32x32 tile) - 11:22.20
2.81 gpu + cpu (32x32 tile) - 10.56.05
2.81 cpu (32x32 tile) - 11.55.26

So there’s some pretty massive slowdown there!

but when rendering with GPU+CPU on 2.81 my cpu hit 83.9 degrees! Every other render it stayed around 70. Very strange.

Weirdest of all - the renders actually look different despite being from an identical file and settings (with cpu or gpu).

Will post pics tomorrow for comparison…

1 Like

I’ve given up on OpenCL. My r9 390X is just a bit faster than my 6-core i7. I render with CPU as I can use my computer while it renders. OpenCL kinda locks up my computer.

The bottles (2.81 on the left 2.80 on the right)

Same file.

Very strange!

Note that OpenCL rendering on GPU’s hates small tiles. I rased that as bug report thinking that it was fixed, but got confirmation that only CUDA was fixed for small tiles, not OpenCL…

very interesting… wasn’t aware of that.

What settings do you find optimal for the vega 64?

Only recently acquired mine and still figuring out best practice.

I found running in hybrid at 32x32 (i have a Ryzen 2600 running @ 4ghz) seemed to give fastest results so far but maybe i’m missing something!

GPU wise, 128x128 based on earlier testing, link below.

raised a ticket but again wasn’t an actual bug :frowning:

1 Like