(VSE) Audio in Meta-Strips Plays Beyond Strip Cut

NOTE: I already submitted this as a bug, but if 3PointEdit or anybody else could take a look at this and give their thoughts (and, God willing, a solution!) that’d be good.

This issue is somewhat hard to articulate, so please bear with me.

I have HD videos with audio tracks >
I set the audio volume to 0.000 because, USUALLY, I will not need the audio (though in some cuts I will) >
I then applied a Transform Strip to the video (to prevent them from distorting to the render dimensions) >
I created a Meta-Strip from these (combining the HD Video, audio, and Transform) >

So, I was slicing-and-dicing the new Meta-strip, cutting as needed. After a while, I got to the part where I needed sound for a cut. So, I:

Tabbed into the Meta-strip so that I could access its component parts >
Selected the audio strip >
Set the audio to 1.000 >
Tabbed out of the Meta-strip’s Edit Mode

I placed my new cut where I wanted…and then this apparent bug was revealed: for some reason, the audio now plays for the ENTIRE strip. The specific cut where I needed the sound is only 5 seconds. The whole Meta-Strip is 2 minutes. Well, for some bizarre reason, when I go and set the volume to 1.000, now the volume plays over the entire length of the original Meta-strip, even though I now just have a five-second slice of it! I’ve tried everything I can think of to keep the audio limited to the 5-second cut its meant to be at, but this bug always plays the original strip’s full audio.

Along this line, I would like to make the related request (though I know this is not the place for requests): For VSE Meta-Strips which contain audio tracks, please allow the Properties (“N”) window to control the volume. You can control the Opacity of its component visuals, so it only stands to reason that you should be able to do the same with the audio. This would save much effort in always having to Tab into the Meta-Strip’s Edit Mode.

I cannot attach a .Blend since Blender doesn’t allow you to link video files into .Blends (plus this is a huge, messy file, as well.)

Thanks to everybody at Blender, as always, despite this frustrating issue.

I usually just delete the audio strip completely if I am not using it. Audacity is a program you can use to strip the audio from something then adjust it then you can save it as its own Audio piece Audacity is Free.

I need the audio for many of the cuts. It’s a long, ten-minute video and I’m probably making fifty cuts. Perhaps ten of them will have the audio. The cuts are very specifically cut down to individual frames, and hoping to just slop-sync it later on is procedurally inefficient and technically unsatisfactory.

Sorry I submitted this bug ages ago and it got “fixed”, but apparently not really. Basically audio strips that are meta-ed then un meta-ed go weird. They play past frame start/end and loose contact with keyframes (f-curves).

I hope you get some help with it, I had to change my workflow to avoid meta-ing strips! Very annoying as this is the ONLY way to achieve strip sync in Blender (moving multiple strips together).

I am rather afraid you have stuffed your blend file or at least have to re-import the audio and try to match frames. I noticed this with the Jump 2 Cut script as it performs edits with Meta strip copies. Oh well. Hmm, maybe a quick tweet is in order too…

Thanks for responding, 3PointEdit, but I wish it were with better news!

Oh well, I guess we’ll have to wait until one of the programmers really sinks his teeth into the VSE, since there are many other significant imperfections in it.

On an optimistic note, the Bug was just assigned to somebody, “Joerg Mueller (nexyon)”. Hopefully he can fix it. I’ll make sure to update this thread whenever the Bug is updated.

Yeah nexyon is the audio guy for VSE, he has done some amazing stuff already. He was able to fix the keyframe issue from some time ago (no f-curves working in meta strips IIRC). If you were able to supply a .blend, even a simple one, then I’m sure he will be able to fix it up. Watch the commit logs!

Okay, I’m subscribed to it, so I’ll make sure to respond to anything. Hopefully, the detail I provided already is enough for him to get a handle on it.

If anybody has any suggested work-arounds for this, I’d appreciate it. I submitted the bug report and they requested the .Blend, which I sent, and they’ve gone silent since. So I’m kind of just stuck on this personal project that I’ve been working on - off and on - since October or November. So any ideas are appreciated.

Have you tried an earlier build of. Blender? Perhaps the bug is recent.

No, although I did try an SVN from a few nights ago and also, now, 2.63, and it persists.

I guess that’s an option, though. I’ll download 2.60 right now and see how that goes.

UPDATE: I just tested out the issue in 2.60 and it was still present in that old release, too.

Sorry to hear, I guess you may have to try matching audio frame times? I don’t know how many cuts you have made but I wonder what happens if you do a mixdown file (from the scene audio tab) of the original audio and substitute the camera audio for the new mixdown into the Meta-strip? My guess is that it is a datablock handling issue but maybe it has to do with linked medi instead. Unlinking in this way might help (if it isn’t strickly an audio issue).

I’m trying to avoid wholly separate audio files, but I will try this…if my own latest-and-greatest work-around doesn’t work.

What I’m doing right now is rendering out the whole Meta-Strip as its own video file. Then, once that’s done, I’m going to re-import it, but this time I won’t need to “Meta” it, obviously. Then, we’ll see if I can make the cuts and control the audio on them individually.

Of course, even if this “works” it’s still kind of crappy because (a) I’m losing a generation of a quality, (b) the original process failed, © it’s a huge waste of time - several hours - with the extra rendering required, and (d) it’s just adding still more steps. But it’s better than not being able to do ANYTHING, I guess.

I’ve been rendering out the source files?

I have to say that I’ve had so many audio problems with the Meta-strips that I’m amazed that this isn’t reported more often. Audio problems with Meta-strips appear to be outright epidemic. I mean, like 50% of my set-ups have yielded problems somewhat like the one I originally reported. This is a major, major issue.

Honestly I thought that too. But I think the usual way to use the VSE is as a sync system for animation Therefore you would lay up audio strips, time your animation to it then add the rendered scenes TO the audio. No meta sync required.

Where as we are using it as a video editor. It would be much more useful to sync audio and video without meta-ing as we often need to alter the start or end of each independently (L cut or J cut), which you can’t do in meta-strip form. Multi strip Sync lock would be a great feature for strips

Yeah, I think that you’re right that the VSE was designed for editing Blender footage first and external A/V second (rightly so, of course). And so there are bound to be oddities in the translation, like the one that’s occurring here.

A Multi-strip sync lock - which would be functionally the same as Meta-ing, but would allow easier and greater control over the component strips - would indeed be very helpful, I agree. (And, presumably, kind of easy to implement.)

At the Bug Report page, a guy named David McSween made a great and helpful observation: the Meta-Strip problems only occur when the Meta-Strip is a copy (which mine is). In the original Meta-Strip, you can get in and make cuts on the audio. (Although you still get an “ERROR” message when you try to keyframe the audio.)

I guess that everyone who’s ever worked with metastrips (after the 2.5x series) for video editing has experienced all sorts of problems.
What’s worse, in my experience problems with meta-strips are not limited to audio: if I trim a strip and meta-strip it to avoid any further manipulation, oftentimes un-metastriping returns the full original clip, not the trimmed one! :0
At first I thought it was just me but the problem was recurrent: starting from scratch with a new blend file made no difference compared and neither did using newer versions where supposedly the bugs were fixed. I’ve had too many problems with metastrips last year that I simply gave up on using them. I ended up locking the strips when done trimming them in the timeline. Not as pretty but it did the trick.

Oooh check out Nexyon’s new commit for this bug. Looks interesting.

Can you link? What do you mean looks interesting?

Here is the commit:

Revision: 46035
http://projects.blender.org/scm/viewvc.php?view=rev&root=bf-blender&revision=46035
Author: nexyon
Date: 2012-04-28 13:16:29 +0000 (Sat, 28 Apr 2012)
Log Message:

Audio:

  • Fix for [#31099] Audio in Meta-Strips Plays Beyond Strip Cut
  • Adding a split files option to the mixdown operator which then renders each channel into a separate file

That revision number tells you to look for Graphicall builds later or greater than that figure.