Why wont Blender load

I’ve downloaded the .zip version of Blender fro Windows and everytime I try loading it, it wont and automatically goes to non-responsive. I check in Task Manager to see if its taking awhile to load in RAM or is it CPU intensive but it isn’t; I also check to see if I have enough RAM and CPU and I do. Thanks in advance :slight_smile:

Hi Elihu5991.

Make sure you have downloaded the correct version of Blender for your OS.

There are normally two versions of Blender 32bit and 64bit AND two install types, .zip based and “auto” install.

Try downloading the “auto” install version, for the correct OS and try again.

If you are still having problems, re-post to this thread and I’ll take you through some standard troubleshooting procedures.

I’ll need to know your Windows version and what service pack you have installed.
Also your graphic card setup and that you have all your drivers up to date, (before we go any further).

Best Regards.


Oh by the way: depending on the Blender version you are using, you may have to install a newer version of Python as well as the correct C++ redistribution.

I’m having a similar issue…I’m on Ubuntu 11.10 64-bit.

When I open blender, a frame and title bar open, but it immediately goes to a white screen… No errors in terminal.

I installed Ubuntu today because I couldn’t get Blender to work at all in Fedora 16.

Any ideas?

ended up using a different video card driver…reboot… now its all working!



Well, I’m having to run it in XP SP3 Compatibility mode. That’s the best way I get it to work. I’m running it on Windows 7, hence, my appearance changes to be more compatible with the program.

About downloading Python, I installed Python nor it’s C++ Distribution, unless it comes with Windows 7. However, I do a portable edition with some IDE - I got it when I was going to start learning Python.

I’m on a community library network, so I am limited to 2 hours daily, (if I can get a booking), so if I do not respond immediately when you post, it does not mean I have given up on you. You WILL receive a reply.

Sorry Elihu5991, I should have made it clear. It’s the MICROSOFT Visual C++ Redistibution Files, download from MS, (free). There are a number of .dll files that are needed for Windows to interface correctly with Blender, (including font and visuals).

Just Google: microsoft visual c++ redist.

There are x86, x64, service pack 1, RTM and security packs available.

If you are happy to run in compatiblity mode, then no problem.

But if not…

Your machine: Laptop / desktop/ make and model.

I still do not know your graphics set up. This is very important as certain graphic arrays, (especially Intel “onboard” based), can have problems.

Direct X version updated? Check to make sure there are no current problems with the latest Direct X drivers, (there often are teething issues).

Try using the standard Python edition and see if the problem resolves.

Is this the first install of Blender on this machine? If not, please make sure that OLD Blender scripts and addons are not located or accessible to your newest Blender version, as this can cause compatibility issues.

Check MS Windows error logs, and see if Windows managed to “trap” the problem, before Blender hung. If it did, post the error code, and reason for load failure, (if necessary).

Check is you need those MS Visual C++ Redists, (2010, last update)



Not sure if this thread current shows only month but no year. Today is Feb 3 2019

Anyway new install on Win 7 Pro 64 bit version. Click to start get brief CMD window followed by a full screen empty white frame with Blender logo for a fraction of second then nothing.

Found on there thread where same problem was “solved” by removing and installing the 32 bit version which in my mind is not a solution but a step down compromise. I prefer to use full capabilities of system which cannot be done running 32 bit versions.

Any help appreciated. :grinning:

Please provide more info, what version of blender did you download? What is your system specs/hardware?

It is the most current 64 bit windows version available here (2.79b) cannot launch to verify version.

System: Windows 7 Ultimate. HP Quad (hyper thread 8 ) i7 3.4GHZ 32GB RAM several terabytes HDD space

What video card?

Can you open a Command Prompt window and navigate to the location of blender.exe and run it from the command line so you can see if there are any messages displayed before it exits? (so the command window won’t close before you have a chance to look at it)


New to blender here. Using Blender 2.79

Last place I wanted to end up is the tech support section first go around. Long story short: Downloaded blender yesterday, worked great and opened multiple times with no hitch. Today hitch.

I have checked both windows and gpu 2080 drivers (all up-to-date), noted that I don’t have a physical HDD but two SSDs (970s) m.2 (if this has anything to do with blender while being put in a C:/ folder but physical has no HDD to go to except a external one). Seems ok here so far, but still won’t load.

I also recently downloaded an old Bamboo Fun driver from Wacom and wondered if that was an issue (haven’t checked yet).

This is the image (if it shows up) that the CMD prompt opens and flashes but the last time I saw it yesterday there was more on it than just one line. Then blender opens splash page but it is white then immediately shuts down after a few seconds.

Any ideas what might be the issue?? Help would be appreciated.

P:\Program Files\3D\Blender>blender.exe
found bundled python: P:\Program Files\3D\Blender\2.80\python
Address : 0x000000014009AAE0
Module : P:\Program Files\3D\Blender\blender.exe

P:\Program Files\3D\Blender>

What video card?

Monitor 1
Name DELL E2211H on Intel HD Graphics 4000
Current Resolution 1920x1080 pixels
Work Resolution 1920x1042 pixels
State Enabled, Output devices support
Multiple displays Extended, Primary, Enabled
Monitor Width 1920
Monitor Height 1080
Monitor BPP 32 bits per pixel
Monitor Frequency 60 Hz
Device \.\DISPLAY1\Monitor0
Monitor 2
Name 2252W on Intel HD Graphics 4000
Current Resolution 1920x1080 pixels
Work Resolution 1920x1080 pixels
State Enabled, Output devices support
Multiple displays Extended, Secondary, Enabled
Monitor Width 1920
Monitor Height 1080
Monitor BPP 32 bits per pixel
Monitor Frequency 60 Hz
Device \.\DISPLAY2\Monitor0

Ok, seven year-old CPU-integrated graphics. Don’t be expecting too much, but it ought to be possible to make it work (I think!) I’m kind of surprised that 2.79b isn’t working out of the box.

Is this a laptop or desktop system? If it’s a desktop you might consider investing a little in a real video card, something like an Nvidia 1060 6G or a new 2060, or one of the new AMD cards even. That would get you GPU-accelerated Cycles rendering too.

I’m assuming here that there isn’t already a “real” video card in the system that’s just not in use for one reason or another.

I would try downloading the current experimental 2.79 (or even 2.80 beta) version from:

and see if you get any different behavior. The 2.80 version also has some command-line options to try various workarounds to Intel integrated graphics issues that we can try if necessary.

I use this as-is and have zero gpu issues with any other program including rendering iRay scenes (though not real fast). Has dual monitor support which is quite handy

I have two other machines with Nvidia cards ( Another i7 and a dual CPU Zeon ) so high end graphics such as an add on card not necessary for this machine. Also the PCI slot on this MOBO is roached so physically not possible to even plug in.

I have basically two options. Make Blender work or do without.

So, did you try one or both experimental builds?

Ok. So there are sometimes when blender opens and when it doesn’t. I tried the 48khz. Seems ok when I went into user prefs to check. Now it opens like normal Read Prefs on command prompt but it still crashes almost immediately and if I go to the directory and delete the userpref file, it goes back to the 44100khz; found 448khz instead, again. So what seems to be the issue since I never really know when it works and doesn’t?

Tried deleting userpref file at the advice of someone. How can I get it back?

Running windows 10 and just downloaded Python 3.8 b/c cmd prompt came back saying ‘file not found’ essentially and I dont think I have python on this computer until now.

The “khz” messages are normal and should not indicate something that will cause Blender to crash. It’s just the last message displayed before the crash, but probably not related.

Blender comes with bundled Python, which you should be using while you’re trying to figure out what the issue is. Blender should be using it unless you explicitly take some action to point it at your other Python install.

The old Bamboo driver could actually be related. I would recommend removing that entirely as a test and see if it makes a difference.

Your SSD drives should not make any difference to Blender.

If you open up a Command Prompt window and navigate to the folder that Blender is installed in and type “blender” there to start the program, then the window will not go away when it exits and you can see if it is outputting any other messages when it quits.

If you haven’t, you should try the latest experimental 2.79 and/or 2.80 builds from:

Either of these will support GPU accelerated Cycles rendering with your 2080 card which the old 2.79b version will not.

Be sure you’re running the 64-bit version of Blender not the 32-bit version (presuming you have a modern 64-bit version of Windows). There have been issues with the 32-bit version intermittently not starting when run on 32-bit Windows.

If you go to User Preferences and push the Save User Settings button it should recreate the saved preferences file.