Wiggle Addon Question

I’ve noticed that when I use the wiggle bone addon (this one: Wiggle 2), whenever I try baking the wiggle it doesn’t turn out how it previewed during playback. To test this I have two simple objects that are the same with the same wiggle armature and settings, and then I try baking the one on the bottom. But even if I try baking the wiggle with or without additive bake selected, or whether I try baking the action itself from the animation menu, it’s always different from the playback before I baked it. How can I have the armature and wiggle behave as it did before it was baked? I also recall seeing some addon that keyframes the viewport playback but I don’t remember what it is.

Here is the test file:
wiggle_test.blend (1.2 MB)

i tried with your scene, using the same wiggle setup on both armatures. the top one is baked to keyframes, the bottom one is the live viewport wiggle. i seem to be getting matching results. have you verified that you have ‘play every frame’ set in your timeline properties? wiggle is calculated on frame update, so if frames are dropped, that changes the input for the physics calculations.

1 Like

Yes, it looks like I have ‘play every frame’ setup in my timeline properties. But it seems even then that when I bake the keyframes the actions seem slightly different. But I think now I realize that’s because the unbaked armature looks different when scrubbing through the timeline, right? I think I see a possible solution as well to this. I noticed one mistake I made was still having ‘Wiggle Armature’ selected after I bake the bones. Turning this off seems to help. Another method I tried is baking the action from the pose menu and then turning ‘Wiggle Armature’ off. Do you think this is a good solution? Also, what does additive bake do? I wasn’t sure what the difference was. Thanks in advance for all your help!


Ahh, from that screenshot you shared, it looks like you are using the original version of the addon.

The wiggle 2 link you included in your first post is for the rewrite, which disables the armature after baking automatically. (but you baking and disabling it manually is essentially doing the same thing)

The original addon does this too, but you’ll want to check the setting to disable the armature in case it somehow got changed:

also is is possible you have both the original and version 2 of the wiggle addon enabled in preferences? that could also be causing issues.
Screenshot 2023-05-11 at 5.19.12 PM

lastly the additive option on the old version of the addon is kind of broken. blender used to be able to bake an additive blended animation layer in the nla, so only the difference between the base animation and the wiggle effect was keyed. the functionality broke in later versions, and its not even really necessary for it to be additive blend mode anyway. in the newer version, the option is just to move the active armature action into the nla, and then store just the wiggle keyframes in the active layer. the visual result is the same. you can also choose to bake directly into the current action, but this is destructive if you had keyed some base animation for the wiggle bones.

Nope, I only have the one. And yeah… I just now noticed that after I baked the wiggle, I can’t find any other keyframes for my bones in the dopesheet and get an error saying “no suitable context info for active keying set” :confused:

are you familiar with blender’s nla editor? if not, do not use “additive bake” as it would be pushing your existing keyframes into the nla.

also as mentioned it looks like you are using the old version of the addon, so you might want to look into wiggle 2 to see if it works better for you. note the ui is no longer in the bone panel, but as a tab in the ‘N’ panel on the 3d view.

I’m not very familiar with the NLA editor, but when I open it I notice that there’s a strip for the armature’s actions as a whole, rather than each bone. I’ll definitely look into the wiggle 2 version. Luckily it seems like I only have to reanimate a few bones, so in the future I will be more careful when baking. Do you have any more advice for baking wiggle bones? What sort of method do you use when working with wiggle bones for animation?