Wood floor looks washed out in eevee - blender 2.93

The issue is on the upper side, the wood floor looks greyish like some strong light hit on it, so i’ve tried to turn of the sun lamp, lower environment lighting intensity but nothing changes. On the down face of the floor though, it looks normal, which is confusing.
Really need help to get the material setting right, thanks!

1 Like

You must use Specular map or decrease Specular value (under 0.1). Blender PBR does not calculate good when you want create high roughness non-metal materials with Metalness workflow. You must use Specular workflow for like wood materials.

Or you can use VSHADE Professional Shader System add-on.