Zbrush Theme for 2.7x and 2.8


I made a version of the Zbrush default theme for Blender months ago but the colours I used was guess work. I decided to sample the actual colours of the software and make changes here and there for readability.

Here’s a preview of the 2.79 version:

The themes also work for BforArtists 2.79 and 2.8.

Blender - Zbrush Theme v-1-2.zip (166.9 KB) (With blue theme).
Blender - Zbrush Theme v-1-2.zip (157.1 KB)
Blender - Zbrush Theme.zip (157.1 KB)

Who is this theme for?
I recommend this theme for Blender users who frequently sculpt models. The dark colours work well on the eyes.

What matcap are you using?
I’m using Zbrush’s default grey matcap. I’ve packaged them with the ZIP file.

How can I use this matcap?
Go to the Viewport Shading pull-down, click Matcap, then click the gear icon to the right. This brings up the Preferences window. Next click the Install button in the Matcaps header. Locate the folder you installed your custom matcaps (in this case Blender – Zbrush Theme ), select a matcap of choice and click Install Custom Studio Light.

DeviantArt page.
Gumroad page.

Feedback is welcome. :slight_smile:

UPDATE: I’ve updated the shade of orange!

6 Likes

Thanks, this is looking great! Also, thank you for the matcaps as well, really nice touch.

One small thing, the orange in your theme seems to be a bit more towards the red -

orange

1 Like

You’re right, it does! It must’ve been the picture I was using.
Zbrush%20colours%20redder

I’ve finished swapping all the colours out from the darker orange colour to a lighter colour. I’m going to convert it for use in Blender 2.79, then repackage everything. Thank you for waiting guys!

1 Like

And done! Enjoy. :slight_smile:

1 Like

Hi. This is a good idea to create a Zbrush theme for blender 2.80. :+1:

I just have a few suggestions, if you don’t mind:

  1. The vertex size could be lowered a little bit. Size = 5 is enough, imo.

  1. I know that Zbrush has “plain color filled panels” but mimicking its UI the same way obscures the Blender 2.80 3Dview a lot. Could you consider not filling these parts with solid color? At least, the N panel.

  1. I think that the background color of panels is too dark, a color like “Hex 2b2b2b” (for the background color of Panels, Preferences, etc) would fit well.
    Reference: https://cdn.80.lv/80.lv/uploads/2018/05/vadim-sadykov-helper-screen.jpg

Thank you for your theme.

1 Like

Thank you for commenting! Reducing the dot size is fair. My computer screen is large, pixel-wise, which could make it look weird on other people’s screens.

As for the T and N panels, that was certainly a choice on my part. I often have the panels fully opaque as it doesn’t bother me too much. If the panel opacity is bothering you, you can go to Preferences > Themes > 3D View. Click on it to expand the options for it and scroll to the bottom of it to Theme Space. Click on the dark grey next to Region Background and change the alpha (A) to, say, 0.5.

And the overall darkness of the grey: I see. My reference image must be outdated. I’ll be sure to update this theme when I can and I’ll let you guys know. Again thanks for commenting, and the recommendations. :slight_smile:

+1 for that.

loving this theme, actually just switching from using a modified version of the awesome theme for this one, being a long time zbrush user.

About the panel backgrounds, there could be just a tad of a distinction, sometimes it’s a bit hard to distinguish buttons and lists.

Definitely plus one for the vert size, I have yet to test it on other workstations but on my macbook they seem quite big -

2 Likes

I’ve made some changes, as requested.

You’ll notice there’s less orange on screen. I feel it was hard to read some text, especially on value sliders, so instead I used varying tones of grey instead. Any thoughts?

I like the new lighter color that you used for the background but I have mixed feelings about the half-transparency. :thinking: :neutral_face: It’s not really Zbrush-like.

As I said earlier, I would still prefer a 100% opaque background color but without the color filling the N panel. I guess it’s a matter of taste. Let’s wait for other user opinions. :slightly_smiling_face:

Thank you for the feedback.

Didn’t you ask for the N panel not to be solid? I’m a bit confused as to what you’d like. When I change the transparency of one it also changes the other. It’s all or nothing, sadly.

Sorry if I didn’t expressed myself clearly, english is not my native language.

I just think that a theme should not fill the area below the N panel with half-transparency color or worse, a 100% opaque color. imo, this area should be left visible all the time.

Oh! Okay I understand. Don’t worry about it. It happens. :slight_smile:

I see it. Visible panel headers but invisible region backgrounds. The way to handle that is to keep the header panel fully opaque but make the region background invisible (as explained a few posts ago). Expect another preview soon.

1 Like

Here’s more progress. The background is now different from the gradient as seen last time. The gradient wasn’t looking as I wanted it to so in the end I gave up on it and replaced it with a flat grey background (of which I think it is now by default anyway).

Of course, when you download the theme you can customize it to your hearts content. :slight_smile:

2 Likes

The 1.2 version of the theme is up for download now!
Blender - Zbrush Theme v-1-2.zip (157.1 KB)

2 Likes

UPDATE! I’ve made a blue variant of this theme. In this alternate version the orange is replaced with blue. Now there’s two themes to choose from. The theme has been added to the ZIP file. :smiley:

Blender - Zbrush Theme v-1-2.zip (166.9 KB)


1 Like

Working on a brand new theme. Can anybody guess what it’s based on? :wink:
It’ll be finished by the end of the day, or possibly tomorrow.

I’ve never been much of a Zbrush user and I’m definitively not a fan of monochrome icons so this is probably not for me, but it does look nice and clean. :slight_smile:
Nonetheless, I have a few suggestions:

  • Selected text in Outliner should be black
    image
  • There is (almost?) no difference between selected and unselected tabs, I’d suggest setting Tab Active to orange es well
    image
  • Font size of 10 is pretty small on a 1440p display

Hello! You have the old version of the theme. Version 1.2 remedies this. :slight_smile:

As for the white text on orange: I tried making the text black but I was unable to. I also tried orange tabs but I was unable to change the text from grey to black, so in the latest version I stuck to using more greys instead.

Also sorry about the tiny font. my laptop display is 4K, so icons normally look super small.

I would also prefer orange active tabs.