3ds max to blender FBX IMPORT/EXPORT

Is there a functional way to import and export from blender to 3ds max and back without having sh*@O#F of issues with scale?

I’m wondering the same.

Objects exported between the programs visually look fine, but scale 100 from Max shows up as 0.025 in Blender (despite cm as system units), and scale 1 in Blender shows up as 10000 in Max…

You fix this by reset Xform in Max, and applying scale in Blender, but it’s still a hassle.

Still nothing new here. And blenders scale is off. It should not export objects reset to 0.01 scale. I have no idea why it’s doing that.

Have you tried changing the scene scale?


I get problems with animations in Unreal if my scene scale is not set to centimeters.

Whelp that works. But there is a nasty side effect of changing that. Nothing in blender works as it supposed to after changing unit scale to 0.01. Many addons are broken, when you try to type measures they are in cm instead of m… And if you have a scene made in blender with sizes of 1 blender unit when you change scene scale nothing changes but scene becomes bigger. So I can’t use already made meshes without changing and applying the scale. Although I might be missing something.

I’m afraid that’s the way to go, yes. You might want to set up everything correctly in a new file and save it as your startup file, so at least new props work right from the start.

There’s nothing wrong with Blender’s scale. It’s just different. Internally, Blender uses 1 generic unit = 1 meter. If I recall, Max uses 1 generic unit = 1 inch. That is, of course, unless you treat the generic units as a different system (cm for example), or changed the unit scale.

Either way, figure out what unit scale you are using in both applications, do the scale conversion math, then use this in the fbx import settings (NOT the scene unit scale.)

Thank you for your help I have tried that already but problem is that for example retopoflow goes wackedydoo with selection when I set scene scale to 0.01. You can’t select anything. Literally. And it’s not only one plugin. Many of them do that. If blender could somehow make exports with objects scale set to 0.01 while maintaining size. That would be the best option, unfortunately my programming skills hit wall when I have to go into looping through objects and beyond snippet scripting.

Well I have tried that in with a lot of variation. Problem is that i don’t want to change scales every time I do E/I between the two. And blender has strange generic exporter units. Everything works fine when I set scene scale to 0.01 but then blender doesn’t work as it should.

Again, there’s nothing strange with Blender’s units. blender uses 1 unit = 1 meter, Max uses 1 unit = 1 inch, other apps use 1 unit = 1 foot, 1 cm, or 1 mm. It’s all relative.

Set the appropriate scale conversion in your import settings and save a preset. It’s that easy. :slight_smile:

Or continue to change the system unit scale and accept the fact that some things in Blender are still based on the default internal scale, and you may have issues.

In Max you can set what the units are supposed to be. It´s the system units ( as opposed to the display units). You can set these to meters, centimeters or whatever you want. They are only set to inch by default.

Regarding applying scale in Blender or resetXForm in Max: That is simply what you have to do when exporting.

Actually even without exporting it is better to apply scale if it is not necessary to keep the scale for some reason.

Sorry but if you understand, what am I then doing wrong. I’ve included import with 1cm and 1m scale setup.


Meters import:

Centimeters import:

Notice wrong size in meters import and wrong scale in centimeters import.

Now you need to apply the scale in Max either manually or in the import settings (I haven’t used Max in years, so I’m fuzzy on the details.)
Or do the scale conversion in the FBX export settings in Blender.

That is what I am doing. But that is the problem. Blender and max are somewhat compatible. Substance designer and blender aren’t. Thank you for all your help :slight_smile:

Your last image show’s a scale of 10000. It’s been close to a decade since I last used Max, but if I recall, this should show 100 if you’ve indeed applied (reset xform) the scale.

And you haven’t mentioned Substance designer until now. I’ve never had any issues between the two.

Look, the reason I’m giving you a bit of push back is not to be a jerk. Honestly! :slight_smile: The relativity of scale between different applications is often a source of issues because each one has it’s own concept of what “a unit” is, not because of any flaws in any one system. Each application also has it’s own concept of what active and applied scale means. There’s also a distinction between system scale and display scale. Once you get a wrangle on how each program you use internally defines these things, you should really never have issues with scale.


1 Like

Try to enable actually metric system in Blender.
Meters in Properties editor > Scene > Units.
It is even shown on your screenshot above with default settings.
Default Blender units can be pretty much anything as how treated by importing application.

It shows that because I didn’t apply it for posting picture. To demonstrate my problem. I want to import a file from blender to 3ds max and vice versa without a need for manually rescaling objects or applying scale(resetting xform). And I posted these just in a quest for an reliable solution. It kinda works with resetting scale every time but it’s annoying.

When I do that almost all of the addons go bannanas.

That’s exceptionally great way to explain things. You could put anything instead of “the addons” without any change for details.
That said, setting Units to Metric is standard way of setting measurement system. It should be used for each case related to exporting objects and I haven’t ever found an addon not working with that.

I am getting the feeling you didn’t read the full thread. That is why replayed like that.

Sorry if you did read that allready but I need CM to CM workflow. OR M to M. Not cm>m>scalefix>scalefix>back to cm… etc. If you have a full solution I would like to hear it. But just setting up stuff to Metric isn’t working. And try setting scale to 0.01 and you will see the problems.