A floor board generator

hello, verry useful plugin, I have this bug with vray blender build, you can check terminal output there:


Hi, I’m using your plugin but have still the problem that maraCZ had previous year. See quote:

I still have the problem that the normals seem to be off.
I’m using Cynicat’s shaders and when vieuwing under less extreme to extreme angles there is something wrong with the reflection.
See pictures:

Do you have any solution or do you know what’s going on?
When putting them in Flat-shaded i get better results, but i want them smooth shaded, or is that no option in this case?

Thanks for the plugin and the great support already!


It is called terminator artifact.

a. Add edge loops at hard edges
b. use Subdivision modifier
c. use Edge Split modifier
d. set shading to Smooth & play with Auto Smooth Angle in Normals menu (under Data in Properties Editor)

Look here: How to avoid…

No, this is not exactly a terminator issue. This is rather a problem of the Smooth shading. I recommend to set the shading to Flat. You will have much better reflections.

Having an issue trying to download the add-on. All I’m getting is a wall of text.


You’re at the right place: that wall of text is the addon :slight_smile:

2 ways of downloading it:

  1. Instead of leftclicking on the link, rightclick and choose save as or save link as. It will start downloading a .py file (python extension).
  2. If you are at the wall of text, you can rightclick and choose save as, it will save a .py file

@MaraCZ thanks for the answer, i tried that and got rather good results (don’t mind the balls floating :stuck_out_tongue: )


1 Like

Great work,mate. One thing though. The links lead to an empty page on your blog. I had to search floor generator to get the latest version or am I the only one having this issue?

Again great work :slight_smile:

1 Like

I made a few changes to the script to solve those shading artifacts. I used similar aproach to what HardOps uses for beveled edges.
I also added a few functions like remove doubles and recalculate normals to avoid other ugly problems that sometimes appear at the edges.
You can download the updated addon here: Updated Floorboard Generator
Please note that I am a complete beginner at coding and there is a big chance that I made some mistakes. In my quick test everything seemed to work well.
Here is a screenshot with the new shading:


I updated the addon to be compatible with Blender 2.80. The functionality is (hopefully) the same.
You can download the addon here.


Hi. I have encountered this problem that I can not solve …
I would like a unique material (as I have assigned it) but in rendering I have this result.
What is it due to?

Can you post a blend file with just the floor and the material?
It could be wrong normals or wrong node setup of your material.

Hi @maraCZ.
I solved.
It seems that the problem was the normal map that was corrupt.
Thanks for your time.

I maybe doing something wrong. However, when I install the addon it does not appear anywhere. Not even in the installed addons. I am using the very latest build of 2.8 as of 25.5.2019.

Any assistance would be appreciated.

I don’t know, the addon still works for me. Does it show any errors? Try to uninstall the addon, restart blender and install it again.

I’m having the same problem. I installed via the zip file I just downloaded from github. Your files were installed in my addons directory, but I can find no evidence of the add-on within Blender. I’m running the 05-26-19 18:32 release.

Might it be properly installed but not appear in the Add-ons list in Preferences? Is there a log file I can check?

OK, I tried to reinstall the addon on my PC and it does not work anymore :/. I will look into this issue soon, but right now I don’t have the time to solve it.

I tried to reinstall the addon once more and it worked. I just had to restart blender in between. Before it showed me an error that it can’t find the init.py file so I changed the name of the file to init and packed it into a zip file. This might solve the problem for you as well.
You can download it here:

That doesn’t seem to be the correct way to create a Python package. The “init.py” file should be placed inside a folder, that is the Floor Board Generator add-on’s folder. You cannot place that “init.py” file directly inside the addons folders. (NOTE: the forum software doesn’t allow to display the double underscores at the beginning and at the end of “init” which should read "underscore, underscore, init, underscore, underscore, dot, py)

Anyway, I placed the Floor_Board_Generator.py file from you GitHub repository inside the addons folder (not really, I placed it inside a special folder named addons_extern, but it’s a long story) and it works fine in today’s Blender 2.80 build.

Sorry for my late response and thank you for your comment.
Here is the floorboard addon where the init file is inside a separate folder. It should work now.


updated the GitHub version to be compatible with Blender 2.80. Short article with download instructions and list with articles on my blog detailing (most) of the functionality can be found here.


– Michel.