DAZ Importer

It should be under the finishing tab…but I am currently using 1.6.0.0

Yeah, like @RSEhlers said, it’s under the finishing tab. Just make sure to select the mesh you want as the parent (active selection) along with the geograft you want to merge.

Hello to everyone :slight_smile:

I probably have a logic question but the addon won’t load all the duration of my animation… I don’t know why…Th’ats exaclty stop at 200 in the timeline in Blender but I set my timeline at 1000, I don’t arrive to locate the problem :pensive:

1 Like

Ah okay, I’m using 1.5.1, and it’s not showing up there at all.

I find the solution, the duration of the animation have to be change as well in this dialog box while importing the action :slight_smile:

I’m trying to use IK on a Simple Rig. But it does not working. No errors or anything. Influence does not change anything. If i try snap FK bones influence change to 0.
Rigify rig working fine, but i like simple rig as it has daz bone constraint built in.

Does anyone know if it’s possible to keyframe/animate the sliders under Custom Imported Morphs? I can adjust the sliders and they behave as expected, but adding a keyframe does nothing except change the color of the slider. When you scrub through the timeline, the value of the custom morph remains static.

@ThomasL Are the custom morphs able to be keyframed? Or do I need to convert them to shapekeys or something?

EDIT: Hmm… I’m not sure what the issue was, but in a separate scene with a different character, I am able to keyframe custom morphs as expected. Maybe I messed something up in the original scene.

@sergey_pavlovich I noticed you are complaining about low FPS.

My workflow to solve this is:

  • Disable all modifiers on base mesh

  • Disable in VIEWPORT all meshes except the body. Or, alternatively, disable the entire collection of meshes. This is different than just hiding the meshes, see the screenshot below. The hair mesh is usually a big culprit of viewport lag, but any high poly mesh will also contribute.
    1

  • Disable Drivers. This can make a huge difference for viewport framerate even after the previous steps. See the screenshot below - this button is located in the DAZ Import morph/units panels. This will prevent you from viewing any animation of the morphs/units you made, but you can re-enable Drivers before rendering to bring the animation back.

  • On the Timeline, change the Playback Sync to Frame Dropping. This tells Blender to skip frames that take too long to load, so you can view your animation at the target frame rate even if things are a little laggy. This won’t help if you’re getting 0.5-1 FPS, though.
    2

  • My final resort is duplicating the body mesh and decimating it until it’s so low poly that it is ugly. I like to avoid this if possible but if I have a scene with multiple characters sometimes it’s the only way to keep the framerate high enough to be useful.

I installed 1.5.1 version and simple rig work fine. So it was 1.6 issue.
Also JCMs not working in 1.6 :frowning:

Hello :slight_smile:

I had extra nails on the market to apply on my mesh : https://www.daz3d.com/hand-salon--fake-nails-and-jewelry
That’s work perfectly fine on Daz but while importing with the addon, I have those strange artifact, how can I fix this ?

Daz replace the original genesis8 nails by he new one but Diffeomorphic addon add them both… how can I stop the software to apply the original Genesis8 nails ?

added reply in your other thread…

1 Like

The sliders are just custom properties for the armature object, so they can be animated. I think that I have had problems to change the value if the property already has keyframes, though. If you turn on auto keyframing (the little red disk icon) keys should be set automatically. But it was a long time since I tried that.

Two more tricks to improve performance:

  • Enable scene simplification in Properties > Scene > Simplify and set the subdivision level to 0. This disables all subsurf modifiers in the viewport.

  • Add a mannequin and exclude the original meshes when doing rough posing, see https://diffeomorphic.blogspot.com/p/rigging-section-version-151.html. In the mannequin the meshes do not have armature modifiers and vertex groups, but are parented to bones instead. The armature modifier really slow things down compared to bone parenting, even if each vertex belongs to a single vertex group.

Hello,

I have those errors while importing my animation, what’s it’s mean ?

Thanks Thomas for your hard work, a really powerful addon.

I have the developer version from today, 23.05, and am trying to export an animation to DAZ using your ‘Save Pose Preset’ instructions.
Get this error:

Had this error first with rThightTwist, when I baked the retargeted animation the location was not transferred. I was able to fix that, now he complains about the rHand - I can’t figure out why. What could be the reason?
Thanks

As I wrote on the DAZ site, this happened when you import an animation that affects scale. The offending code is bypassed in the development version, so the crash should not happen anymore, but the resulting pose may be off. If you point me to the file that caused the problem I can check if the pose looks the same in DS and Blender.

1 Like

You probably changed the rotation mode of some bone at some point, so the action had f-curves for quaternions even though the actual rotation mode was some Euler. This should not cause a crash anymore.

Thank you Thomas for your answer :slight_smile:

I’m stil using this version of diffeomorpic : 1.6.0.0293
Wich file should I share with you Thomas ? the daz file with the animation ? Or should I simply upload to a new version of diffeo ? I’m a little bit confuse on the website and don’t understand wich version is the final update.

Here a photo of the bug affecting the animation ^^

I just try to remake the animation with no scale apply to the character, the error is gone but the animation is not apply correctly, arms going in others directions…

Here the same foutage at 120 seconds in Daz and Blender