Daz to Blender8

It depends when you wanna use a model in a game you have to buy an extended license (50€ per model), if you just render something picture/animation and make money with that, it’s fine.

How about commercial Arch-Viz project ?

To my knowledge:
If everything you produce and distribute are rendered images/movies, you’re fine. Only when you distribute mesh geometry or raw textures you need an extra license.

Thanks you very much.

Hi Mitchy,
first i wanna say big thank you for a really good plugin. I mostly use Blender for creating a models of everything. But i wanna try also do some charaters in better quality. Your plugin was answer for what i was looking for.
But i have one question about it. In solid viewport has imported character (without nothing) round about 450 MB in RAM. But when i select material preview or rendered viewport, it has after small freeze (5-10 seconds) 2,89 GB or more. Issues is more noticable when importing with clothing, hairs and other stuff. Has somebody else same issue? I have applied hairs on my character and that i will do the clothing in Blender, but after reaching 10+ GB in RAM Blender crashed. I have in my notebook just 16 GB RAM.

Thank you very much for your ideas how to solve this issue.

Hi Chladic88.
If it crashes due to occupying too much memory, it may be possible to prevent the crash by lowering the priority of Windows 10 processes.
Of course, Blender itself can be slow.

Mitchy

Hi Mitchy, im affraiding, it didnt solve the problem. Any other ideas about RAM issues?
What could cause almost 10 higher RAM usage, when switching the viewport mode to workbench / render?
Also wanted to ask, you are planning to add the Eeevee support? Cycles is melting my PC down :frowning:

Hi Chladic88.
I guess the latest version has the minimum adjustment to support EEVEE.
I’m not very familiar with the details of how to configure Blender, but can we limit memory usage at image locations?


Was this a problem only when editing videos?
Also refrence ↓

Thanks Mitchy for helping, but unfortunately, even if i reduce these numbers for Undo memory to 250 MB and Cache sequencer for 1024, it is still crashing and model imported from Daz has still same behavior. That means, after switching to workbench vieport, default model has 4 GB in ram.

Can you tell me the product name or specifications of your current PC?
Especially in the case of notebook PCs, the graphic board may be a bottleneck.

Yes, i have notebook Asus ROG STRIX GL503VD with 16GB RAM. Processor is i5-7300HQ 7th generation and graphic is nVidia GTX 1050 4GB.

That’s a great PC. The specifications seem to be enough.
Download the portable version of Blender2.79b from here.↓
https://download.blender.org/release/Blender2.79/blender-2.79b-windows64.zip
Unzip and launch 2.79b with Blender.exe, install DTB_v279.zip and check if it works properly.
2.79b is said to be the least buggy of all versions of Blender to date.
If it works, you will need to reinstall Blender 2.8x.

I have tried it on that version of blender. Default character female gen8 after loading has 373 MB in ram. When switching to material, it is 2890MB in ram. When trying to do it with some hairs, it did crash :frowning:

Hi Chladic88.
I forgot to ask you about troubleshooting item Q3 on page 13 of the manual.
Depending on the DazStudio environment, too many shape keys may be transferred to Blender.
In many cases, changing the value does not change the mesh.
Too many such shape keys consumes a lot of memory.
You have the option to delete all such shape keys during the import phase.
Previously, the checkbox was “Skip Invalud Morph”, but now it is specified by the command “#clear morph”.
Try this option.
Reference images are also attached.

Hi Mitchy, maybe im blind, but where exactly i can find this option?

As stated in the manual,the option check box has been removed, and it is now a word command option.
Before pressing the import button, enter the command “#clear morph”.

Hi Mitchy,
I faced a problem using the add on with genitals. All the vagina shape keys works perfectly but when the anus is opened it distorts the shape of vagina. So ı decided to make a new shape key for openning anus, but “to sculpt mode” button gives the warning; “this feature is not available on genital figure”. When I go to edit mode without using “to sculpt mode” it is not possible to move any vertice, so I can’t form my new shape key. Do we have any solution for this?

Hi Olympian.

Even if you create a morph using a genital figure, you cannot create a morph using DazStudio’s MorpLoaderPro.
So, from the beginning, it was impossible to create morphs. However, it is inconvenient if you want to create a morph (shape key) only inside Blender like this time.
So, in the next version, I want to prohibit only exporting morphs.
However, it is still possible to create shape keys. All you have to do is add shape keys and manipulate them manually.
Plus, the next version 1.8 will be uploaded within a few days. Gumroad will notify you of the upgrade, so please try it when you receive it.

Mitchy

Thank you Mitchy

Hi again Mitchy,
I faced another problem with a character. In daz3d after hitting the daztoblender8 button, everything seemed normal processing but at the end I got the “an error occured while exporting, see the log file” mesage. After that I tried to import in blender anyway but “appropriate fbx does not exists” error comes. Where is the log file stored about it? I think maybe we can find what is causing the errorin that file.
Also I would be glad if you can tell me, in case of successfull export, where is that file stored, I will ask my friend to try it and send me that file if the export is successfull.
Thank you.