File output node & default output

Hi!
When using file output nodes to save rendered images, is it possible to disable the default output file, so it only saves the files I specify with the file output nodes?

If I understand your question correctly, to save only the File Output node data all you have to do is disconnect the Composite node.

I use File Output nodes all the time; I prefer them to the default output. However, it seems that Blender will not render without something going into the Composite node.

When I’m using a lot of File Output nodes, I’ll create a “dummy” output for the Composite node (something like an RGB node into the Image input for the Composite). Then I’ll have four or five File Outputs that do all the work.

Thanks for your answers!
I had actually deleted the Composite node, and it did render, but it also saved the default output file, and it was kind of unpredictable which render layer it chose to save to the default output. I’ll bring the composite node back and go with the dummy output idea.

I also had trouble with the default output still outputting frames, and worse: overwriting already rendered frames! Disabled render layers or turning off the compositing didn’t do the trick.

The dummy approach is a workaround, which is a solution, but I don’t find that very elegant for something that you come across a lot.

i.e. you make some render layers, render them out (which rendered all night), and then just want to render a matte layer from the same scene. You don’t want to re-render everything, only the newly created renderlayer. This is now quite cumbersome.

I wasn’t aware that Blender still writes black frames when you disable the render layer which is connected to the compositor, that goes to the default output. It seems it must output something to the default path. But that causes many unnecessary frames on disk.

Is there perhaps a better way that I don’t know about?
Thanks!

Bumping this - any change?

Bump. May 2020. Blender saves out empty frames (all black) to disk whether the composite node is in the node tree or not. They’ll either get saved to the output path, if one is specified, configured in the output properties tab. Or to the directory of the blender executable. It’s really annoying if you’ve rendered a ton of different shots and passes for each shot, as you then have to go in and clean up all the junk frames. An option to disable this would definitely be welcome.

1 Like

Another Bump. November 2020. It kinda seems like an obvious thing as it’s a redundancy of files (hard drive space) and of processor cycles (render).

To be clear, to anyone not getting it and to echo morritzio, just disconnecting or removing the composite node results in black frames being rendered into whichever root folder is specified in the main project output setting. Removing the path entirely results in a permissions error because it’s trying to write to an unspecified folder.