Google Maps Models Importer

Hi,

I don’t have access to 1050ti anymore, but with the 1060 - I ran it with the setup mentioned in the twitter link and it works perfectly.

Glad it worked out for you and thanks for info!
Too sad I cant get it to work…

–no-sandbox --gpu-startup-dialog --disable-direct-composition --use-angle=gl --disable-gpu-watchdog --in-progress-gpu --ignore-gpu-blacklist --disable-gpu-sandbox

even some env variab RENDERDOC_HOOK_EG=0

Altough tests showed me an overlay, for example quake 2, even google earth telling me mismatching opengl versions… maybe I’ll try again in the future…

how you set up the flag, it doesn’t let me set up. Can someone write the whole line of the flag.

  1. Delete your Chrome browser
  2. Download this version of chrome https://github.com/eliemichel/MapsModelsImporter/releases
  3. Open Properties, in target delete all and paste
    chrome.exe --disable-gpu-sandbox --gpu-startup-dialog --use-angle=gl
  4. Apply and OK

Hello @Mink! Try to use your awesome addon.
I succesfully saved a frame in Render Doc 1.2 - there were no errors. I also look for textures in Render Doc window as you shown it in video.
But when I try to open the frame in Blender no data appears. File have a size 66 Mb. So I try to open your file Capture.rdc - it opened very well - I can see model and textures.
then I tried to use Render Doc 1.1 - frame was saved but there were 3 errors. So this file also have a size but I see no data in blender.
So addon is working very well but what is the problem if I can see all the textures in Render Doc and there are no errors and saved file have a size but nothing is shown in Blender?

Si, por fin consegui que funcionase con esta version de Vivaldi.
Muchisimas gracias por tu aporte…

Hi’ I’ve tried anything but RenderDoc, even though I’ve set up everything correctly, won’t capture the 3D structure but only a black screen with the Maps UI like this:

Immagine|690x145|

Worked only 2/3 times apparently with all depth information, but Blender won’t load it, the console says the following:

Loading capture from D:\rgiov\Desktop\test.rdc…
Couldn’t open file: ReplayStatus.FileIncompatibleVersion
Traceback (most recent call last):
File “C:\Users\rgiov\AppData\Roaming\Blender Foundation\Blender\2.81\scripts\addons\MapsModelsImporter\google_maps_rd.py”, line 171, in
main(controller)
File “C:\Users\rgiov\AppData\Roaming\Blender Foundation\Blender\2.81\scripts\addons\MapsModelsImporter\google_maps_rd.py”, line 83, in main
drawcalls = controller.GetDrawcalls()
AttributeError: ‘NoneType’ object has no attribute ‘GetDrawcalls’

I’m using the correct Chrome and RenderDoc, APIs are detected correctly and Blender is from Steam version 2.81!
What I am doing wrong?

Hi Mink,

I’ve uninstalled my current chrome 80.0 version, but when I install the specific 70.0 version, I have this pop message below.
“PS.” I tried again but I still have the same pop message.

trouble-chrome70

any idea why this happens? running an amd xr 5700 xt gpu.