keKit for Blender (2.8+)

After checking it out a bit more i don’t think this is a 3.0 specific issue in a sense that update_edit_mesh(obj.data, True) does not need True I’ve only tested this on 2.93 though.

If anyone is using 3.0 and wants a fix for ke_clean and ke_merge_to_mouse find update_edit_mesh() and remove True from it. if you are also using an older version then 2.93 and this causes you issues replace bmesh.update_edit_mesh(obj.data, True) with this

        bversion_string = bpy.app.version_string
        bversion_reg = re.match("^(\d\.\d?\d)", bversion_string)
        bversion = float(bversion_reg.group(0))

        if bversion <= 2.93:
            bmesh.update_edit_mesh(obj.data, True)
        else:
            bmesh.update_edit_mesh(obj.data)

make sure to add import re at the top of the file.

update_edit_mesh takes two booleans. The change (in 2.93 or 3.0) is prob that I cant pass one undeclared anymore, probably. (makes sense they fixed that)
I’m not using 2.93 as a daily driver (still on 2.92 mostly) so haven’t encountered it myself,
but I will check for occurrences since it may relevant for 2.93.
ed: fixed all. default is true anyway, so just redundant. will be in the next release.

1 Like

This error didn’t happen in 2.93 so i think it’s fine for now, i just use 2.93 and 3.0 some different branches like sculpt and cycles-x and opened 2.93 and kekit was still working with those changes i made so i left it as it is.

For other people using older versions then 2.93 though i can’t be sure it would work so just wrote up a quick fix for that just to be sure.

Not very familiar with Blender API i have wrote a couple things for my self but i hate the Blender documentation so i don’t bother with it.

Hi! im here again with smooth toggle)

for now it disables auto smooth option,- so need to activate auto smooth every time you return to smooth workflow. (Maybe i miss some functionality about such behavior…)
1
…but it looks like more useable is to just leave auto smooth as is while toggling just shading - object shades flat and then returns to its previous smooth shade
2

and again about triangulation while blender isn’t CAD and not all of issues possible to resolve or quickly fix with ‘Rotate face addon’ or Ke “Zero Scale Normal” its very useful to have possibility to tweak objects while seeing real object triangulation
first part of video i show fixing with shade flat - triangulation - add real edge - use rotate face
second part - manual fixing with shade flat - triangulation - slide verts . As seen it’s much faster especially on complex models

Thanks Kellog there is “T” button now for flat shading, but problem i’m facing - it doesn’t disable or remove triangulation when returning to smooth shade performs

So i suggest two things:

  • do not modify auto smooth checkbox while toggling
  • remove triangulation while smooth display activated.

PS: also reporting again about bug in Ke “frame all or selected” behavior - it doesn’t frame unselected as native one
3

Hey,
toggle : Sure, i can change that.

frame all: I can’t replicate that. Seems to work just as expected on my machine™. It looks like you have some “invisible objects” in the scene that the built-in ignores. But the script literally uses the built-in command for frame all, so there should be no difference. Makes no sense.

1 Like

Found behavior.
It’s all about pivot point. So keKit recognizes pivot point as some kind of object in object


So yes, center=False in this case is the solution.

1 Like

hm… yep if i change “center” to False everything works fine

Thank you!

Ah, I see.
It seems Center is false by default also. Not sure why I changed that. I will set FrameAllorSelected to the defaults as to not confuse things.

edit: v1.438 is up

2 Likes

Oh, man!
Thank you so much!

Hmm, might be something weird in my scene. In a clean scene it works as expected, weird

Hi.
Found that FrameAllorSelected also do not work with Lattice in edit mode.
You select points and nothing happen. Default Frame selected works well.

Hey.
Confirmed. …and fixed ;>
(in next release)

4 Likes

Interesting…
Before 1.438 version “Frame All or Selected” behave smoothly like default blender, but in 438 it immediately moves to selected.
Smooth looks better, isn’t it?

Would be great if FAoS also worked in UV editor window.

Hey! Sure, I don’t really mind either way. Also, now also works in UV editor. :wink:
(next release)

4 Likes

Would it be possible to add an “Align Cursor to world” in your “keSnapAlign” pie?


I find myself wanting to keep the position of the cursor but reset its rotation to world

1 Like

Hey,
Yes, that could prob be useful. I’ll prob call it “Clear Cursor Rotation” jfyi.
in the next release.

4 Likes

Love the update! :smiley:
Yet another suggestion, could you enable entering edit mode on lattice objects using your Direct element switch?

1 Like

Other modes beyond component-modes are on the todo list. No ETA.

3 Likes