Modular Tree

Yes, I deactivated and even deleted the old version.

It works now!
Just redownloaded and its size is larger than the first time I downloaded it, so either the file has been edited after my initial download or my first download was corrupted.

Thanks for the help!


MTree 4.0.0
Blender 2.93.1
Ubuntu 20.10
(small celeron based machine)

It does work here too.

Thank you

Got it to work. Almost lost my sleep how fun this thing is! Great work Maxime!

WOW. This is my new favorite addon. It’s so much better than the expensive grove addon and the annoyingly high resolution of sapling. Not only that, but I don’t feel like it does everything for me in a drag and drop way which totally feels like cheating unlike some addons, and I LOVE that - I feel like I’m creating trees myself by editing the settings! This is some really impressive math and I am seriously blown away.

I just wanted to say that I was able to download version 4 on 3.0 with Cycles X for Windows!!! Though there’s no twigs yet it’s looking really great. Anything below a tree length of around 0.34 makes it crash though haha. As well as changing the resolution while in edit mode.

I particularly love how in 2.92 it lets you create twigs from a given leaf, with automatic branches added - I can’t WAIT for that to be added to version 4 :smiley:

I used 2.92 to make trees and then imported into 3.0 for BLAZING fast rendering of trees!!! Thanks so much Maxime!!

EDIT: I just read Harvester’s post about how to install it for 2.93+, and I CAN CONFIRM IT WORKS ON CYCLES X!!! BLAZING FAST TREES >:D

1 Like

any update for 2.93 version from @Maxime?

Can yo help me to install this addon? I download alpha 4.0.0 bt cant install

Running it on blender 2.93 on 7th gen core i3 laptop and it runs fine. Better than I thought actually.

can you give me a screen shot of your add on folder?

Sure I can do that, but I just downloaded the zip folder and installed it like any other add on.

Did you download the 4.0.0 alpha version?? From github?

Is your zip 271,3 kB (linux) / 110,6 kB (win) or smaller?
Did you install it in 2.93 or a different version?
Did you use “Install…” from preferences - add-ons?
Any error messages?

I am on windows 10. Install alpha 4.0.0 version of windows mtree. I install it through the preference > addon but the add on activation option didn’t pop up. I didn’t find it in my addon list. Blender version 2.93

Hey zigzack001!
I installed the version from Harvester mentioned here. You can just scroll all the way downt o where it says "if you want to avoid work, here is the file with the modifications for 2.93+

1 Like

Oops sorry! I meant to reply to you. Can you see my reply I just posted?

1 Like

Oh, great man. Bt the creator of this addon @Maxime upload a new one on his Github repository did you check that? its 4.0.0 alpha. And thanks again its worked the version you mentioned.

Unbelievable, i stumbled on modular tree by chance. Never heared of it and this goes back to 2016 i read. Makes you wonder what else might be out there i dont know of…

That said, i probably chose a bad time to discover. I can run the 4.00 alpha, but there are only 3 nodes in mtree and all other features i cant find.

I tried 3.00 on several versions of blender including 2.83.17 and 2.93 but none of these versions seems to comply with 3.00. None the less i like to test the full featured mtree version, so which Blender i have to install for it to work?

For blender 2.83 - 2.92 there has a stable version its 3.00. Just download the mtree 2.83 branch from github. It will be work. Dont download master one.
And 2.93 version mtree is not complete yet if you want to use the fix version. Check some previous comments you will find it.

Now, which is the link to download the most recent version of the add-on for the latest official version of Blender? Just asking because I became perplexed.

I’vedownloaded these older versions you mentioned. In 2.83 the addon wont show after install. 2.92 gives the “Upgrade to 2.8x required” warning.

I tried the mtree 2.83 branch as well but same warning.

However, i got the harvester version to work somehow but that version seems incomplete (like no leave creation).

I think i wait for the official version for 2.93

Oh yes, I saw that as well, but honestly the version we have that I sent in that link is really good. I don’t see any reason to need the 4.0 version for Blender 3.0 just yet, and when we finally get it, it’ll be a welcome surprise! :slight_smile: Let Maxime do their thing, they’ve already developed an AWESOME addon haha