My GPU is not showing up in Blender 2.8

hi all Im hoping someone might have some wisdom for me as my NVidia GeFore GTX580 does not show up in Blender 2.8 as an option. For the “Cycles compute device” there is only a button labeled “None” and no option to activate it clicking th ebutton does nothing

1: is my card out of date? It is using latest drivers and compatible with open GL 4.2 works lovely with 2.79 so what could cause it not to be available in 2.8?

2: is Eevee actually using GPU?

3: ive got a crappy laptop at work using NVIDIA Quadro K1100M and that shows up fine as an option for GPU in Blender 2.8 - however it crashes the moment i try to change anything at all!

any help would be appreciated I would hope my card is fine for Blender 2.8 and perhaps its not on the list yet supported?

many thanks all

I’m sure someone else can double check this, but I think I recall seeing that 2.8 requries a minimum of a 600 series card. The GTX750 ti is a reasonably cheap card and requires very little power consumption.

Yup GTX4xx and GTX5xx are no longer supported being Compute version 2 and 2.1.
2.8 also requires a recent driver with Cuda 9.2

oh no! I didnt realise this - thanks for the feedback - I searched but dont find any mention of supported or recommended cards for Blender 2.8 - the gtx750 doesnt seem available on amazon only the 1050 at £169 - ill do some more research

If you want something similar in speed for CUDA compared to the GTX580, you should choose at least GTX 1060, 6GB vRAM version (it also comes with 3GB vRAM version, which you should not buy)

You read here (English at the end):

Clément recommends as much vRAM as possible for Eevee (for CUDA the same is also recommended). Therefore you should at least choose starting from GTX 1050 Ti 4GB vRAM (You make sure that it is 1050 with “Ti” word in model). I am not sure if there are Out of Memory errors with Eevee/OpenGL, but perhaps little vRAM could influence speed/fps.

By the way, supposedly next month nVidia launches new cards, you should wait before buying.

hi thanks for the feedback - I hadnt realised my GPU is now out of date for Blender 2.8 ive seen no articles about GPU compatibility only Open GL compatibility
In my brief research this morning im finding that indeed the card mentioned above EVGA NVIDIA GeForce GTX 1050 Ti 4GB looks the best candidate without spending out too lavishly

But this is for CUDA/Cycles. GTX580 should work with Eevee (OpenGL).

1 Like

hey thanks for clarification! so its only for cycles I would need a newer GPU while for Eevee my current old GPU workhorse will do just fine - will see how i get on many thanks again appreciate the input

I have the same problem with latest blender 2.8. My gpu is rtx 2070. But the cuda recognize the gpu card. Does anyone know how to fix this problem?
OpenCL !

I only can upload one image a time. here is another one.

Hi. What is your OS?

For nvidia cards CUDA is preferred and we hide the card in the openCL list.

The OS is win 10 home. Thanks for any suggestion.

What do you want to achieve? CUDA is always faster than OpenCL for nvidia cards.

I don’t know about CUDA, I thought the problem was a bug. So, with CUDA, the blender works faster on rendering via eevee. Do I understand correctly? Thanks for your help.

Those settings that you show in the screenshot are only for Cycles. Eevee uses OpenGL (not OpenCL) on your GPU connected to your screen. You do not need extra configurations in Blender.

Hi, I have nvidia geforce gtx 1050 on windows 10 but it doesn’t show on blender 2.8
Do you have any solution ? thank you

Welcome to the community Laura !

I have gtx 1080. Running windows update got me good drivers,
same may work for you.

hello i have GEforce gt 635m with windows 10 same problem d

but my render time is same as GPU on 2.79 but I have to select GPU compute while starting the rendering.