Sculpt Layers Addon

It should be fine. But there will be a new update according to 2.93+.

Thanks. The use I’m considering this add-on for is skin detailing on highest multires level with 10M verts or more. Earlier you write that save/hide/unhide layers takes about 17 seconds on your machine, with 16 million verts. Will eg. adjusting layer strength take similar amount of time?

Unfortunatelly, it will take some time to save/edit values. The main problem is that I have no access to the Multires-modifier to change points positions. The amount of time depends on a machine.

But, sculpting works without any delays.

Basically, you sculpt details, then save them.

I am just wondering how the connection to zbrush is currently going. Do you think it would be possible on future updates? This would be really useful for me because I only work with people who use zbrush.

At the moment I’m not sure if it will appear as lots of work to do. But who knows… Maybe in future.

2 Likes

I created a brush manager for Blender called Rune. I hope it will help you in sculpting.

7 Likes

Hi Artists,

Sculpt Layers V0.5 is released and this is a major release. V0.5 is not compatible with previous versions but you can convert layers of an old version to a new version.

  • Updated UI.
  • Layers are moved to Attributes of a Base Layer. Thanks to Geometry Nodes.
  • File size is less now to 10-20%.

8 Likes

Hi Mifth, sculpt layers version 5 works with Blender 3.0 however not really working with 3.1 beta, is that due to geometry nodes changes blender underwent not long ago (attribute v fields)…and will there be a fix, or have I done something wrong??

1 Like

Hi Ivan,

Actually V0.5 should work with 3.1. Do you have any errors?

2 Likes

My apologies Mifth, it seems to be working now (maybe a reboot of blender might have fixed it)…the error I had was that the layers were saving, however when the layer visibility was disable the sculpt information on that layer remained visible…sorry mate!

1 Like

No worries, poke me if you will have any errors.

2 Likes

I’m also seeing Sculpt Layers not functioning correctly in 3.1 (which is released now). When I toggle off a layer the sculpting deformation goes away but the lighting stays as if the geometry was still deformed, and then if I toggle the layer back on nothing changes (no errors).

Can you please provide a simple blend file with steps to reproduce the issue?

Example 1: Default cube remeshed in Sculpt Mode at default resolution (0.1):
20220322-SculptLayers-01.blend (204.8 KB)

Example 2: Default cube subdivided with modifiers applied, shaded smooth:
20220322-SculptLayers-02.blend (884.0 KB)

Each example has 3 horizontal sculpted lines: the top line was drawn with no Sculpt Layers added, then I added the first layer (Layer_0) and drew the middle line, finally I added the second layer (Layer_1) and drew the bottom line.

The two examples behave differently (but neither work correctly), and in my testing I believe the difference is that the second is shaded smooth whereas the first is not.

Example 1: Turn off the visibility of Layer_1 and both the middle and bottom lines disappear, including lighting (bad, only the bottom line is expected to disappear). Turning Layer_1 back on does nothing.

Example 2: Turn off the visibility of Layer_1 and both the middle and bottom lines disappear from the sculpt, but the lighting remains as if it’s still sculpted (bad, only the bottom line is expected to disappear and the lighting is expected to update). Turning Layer_1 back on does nothing.

hey mifth can vdms vector displacement maps be possible in blender like we can use them like we use alphas

You need to save Layers manually.

  • Add a layer.
  • Sculpt details
  • Save the layer

Sorry no. This is for Blender Developers.

1 Like

I’m not sure what you’re responding to, but is this no longer available for purchase?

Artstation only at the moment.

In the latest master version the addon seems to be broken.

Traceback (most recent call last):
  File "/media/data/blender_guest/cmake_release/bin/3.2/scripts/modules/addon_utils.py", line 335, in enable
    mod = __import__(module_name)
  File "/home/guest/.config/blender/3.2/scripts/addons/SculptLayers/__init__.py", line 21, in <module>
    from . import layers_base
  File "/home/guest/.config/blender/3.2/scripts/addons/SculptLayers/layers_base.py", line 4, in <module>
    import numpy as np
  File "/media/data/blender_guest/cmake_release/bin/3.2/python/lib/python3.10/site-packages/numpy/__init__.py", line 155, in <module>
    from . import random
  File "/media/data/blender_guest/cmake_release/bin/3.2/python/lib/python3.10/site-packages/numpy/random/__init__.py", line 180, in <module>
    from . import _pickle
  File "/media/data/blender_guest/cmake_release/bin/3.2/python/lib/python3.10/site-packages/numpy/random/_pickle.py", line 3, in <module>
    from ._pcg64 import PCG64, PCG64DXSM
ImportError: /media/data/blender_guest/cmake_release/bin/3.2/python/lib/python3.10/site-packages/numpy/random/_pcg64.cpython-310-x86_64-linux-gnu.so: file too short

Would be good to fix this for the upcoming beta of Blender 3.2 :+1: