Sculpt Layers Addon

Bspheres has an update. BSpheres Addon - #34 by mifth


Any updates on this plugins development? Any luck getting the layers to autosave without clicking a button?

Also, I highly recommend keeping this thread reserved to the Sculpt Layers addon and post updates on BSpheres to another thread.

Hi Jaidec,
Unfortunately, I’m still busy with other addons. But good news is that next addons will be for you, sculptors.

The next update for the Sculpt Layers will be redesign of data. Then I’ll probably try to add a connector to ZBrush but that’s still an idea only.

No autosave yet, sorry.


Thanks for the update on Sculpt Layers, glad to hear there is additional tweaks and features coming.

I also wanted to report a bug that I have found with Sculpt Layers 0.4.2 and Blender 2.93. It appears that using the Subdivide/Unsubdivide buttons in the addon to step up and down levels causes the data to disappear again. However, using the levels from the multires modifier seems to work perfectly now. Just wanted to give a heads up.


Thanks, could you please provide a file and steps to reproduce so that I could fix it?

Here’s a test scene that shows the bug. If you step up/down the subdivision levels inside of the multires modifier everything works, but if you step up/down the subdivision levels in the addon the details are lost (smoothed).

How I recreated it:

  1. Create a Suzanne
  2. Enter sculpt mode
  3. Add a multires modifier and subdivide
  4. Add a sculpt layer
  5. Sculpt (Changed proportions and added a crease)
  6. Save sculpt layer
  7. Step up/down subdivisions inside the addon

Blender 2.93.2 / Sculpt Layers 0.4.2
Sub_Bug.blend (2.8 MB)


I repeated all steps but all worked fine. Could you please record all steps and show the bug?

Here you go! Thanks again for taking a look at this.
Sub_Bug.mkv (4.5 MB)

Aaa I get you. When you press UnSubd then one layer is removed from subdivision.
SubD and UnSubd buttons are helpers only. For example, you are working on a head and you feel that you need higher/loweer resolution then you can use these buttons.

These buttons work as expected.

1 Like

Oooooh. I get it now! It is literally adding and removing subdivision levels but keeping the layers intact. This is a great feature! Thanks again for the help and clarifying the workflow for me.

it works in dynotopo too?

It does only if amount of points is always the same.

ok many thanks

Really awesome. I can’t wait to try it.
I guess it won’t work with relative detail in dyntopo. Will it?

So is my understanding correct that:

  • to add a new subdiv you use the SubD button in the SculptLayers (not the multires button) irregardless of what’s the current layer is (applied to all of them)
  • to remove the top subdiv you use the UnSubD button in the SculptLayers (not the multires button) irregardless of what’s the current layer is (applied to all of them)
  • to go up and down the subdivs you use the slider in the multires modifier and that again affects all layers
1 Like

Yes, fully correct.

Sorry for the delay. I did not see your post. It will not work with dyntopo as mesh should always have the same amount of polygons.

I guess it’s multires then

I am having an issue. I added a sculpt layer and it was working fine, but my blender file was used by a coworker who doesnt have this addon. When I tried to turn off the layer after my file return to me, I got an error saying that the numbers of vertex dont match. I tried collapsing all layer and clean ui but if I make another layer on that mesh I get the same error. I dont know how to solve this…
I am guessing the problem was that my file was used by someone who doesnt have the addon but I am not sure…

1 Like

It looks like your coworker changed topology of your mesh (added/removed points, detached/attached some parts). And this affected to the layers as the amount of points and their ids should be the same as the original mesh.

You can PM me a problematic mesh and I can have a look at it. But if your coworker changed the topology then there is nothing much to do.

Probably you can transfer points positions of old layers to a new mesh and save them as new layers.