Show Backface + Backface Culling on Glass in EEVEE removes artefacts

Hello.

I wanted to share something strange I came across with the help of the forums - artefacts from glass disappear with some obscure workarounds or tweaks. Hopefully someone can make sense of this or use it to their advantage.

This is tied in with a post I made here: Issue with glass and transparent objects for the web (EEVEE, Verge3D, Webgl)

While following the thread at the below link, someone suggested they assigned the same material with different options on various faces of their mesh. I did the same thing, except that the material and options are identical in every way I could tell and I just used one material slot for the inside-facing surfaces, and another for the outside.
Thread: Any tips for faking realistic(ish) glass in Eevee?

I’m going to add the blend file…
bottles_arterfacts.blend (847.6 KB)

The rendering parameters might be a bit heavy for older computers. At least it lagged on mine slightly.

It looks like we both posted about the same issue at the same time. (4 hrs ago). Glass / Transparent Problems

I don’t do glass too often so I thought it might be my node setup. Now I think it might be a bug. I tried a solidify modifier, but I didn’t think to apply and assign the interior to a duplicate material… trying it now.

I tried the method of assigning a second material to the interior faces… didn’t work for me. When looking at my 2 models, I realized that the smoothier egg shape was a UV sphere that was stretched. The other was edited from a cylinder. I thought maybe the artifacts had some thing to do with the vertice order, so after trying Mesh :arrow_forward: Sort Elements… :arrow_forward: Cursor Distance, I got a new artifact pattern. So there is that. Not quite a solution yet.

I have created a new file with the material on some new geometry.
material problems.blend (946.9 KB)

The settings that cleared the glass of artefacts in my case was to enable Show Backface as well as Backface Culling. I changed the settings in your file to reflect that and the artefacts disappeared. I then changed your material back to the mix of glass with transparency and this is the result:


I’m not sure whether that helps changes anything for you or not.

*I also added a second layer to the sphere to try a more similar situation to my own scene, and it seems to work. Note that these objects only have 1 material assigned. I still went through the procedure of adding another slot, but (at least on the sphere) I removed it and it didn’t break the material.

Thanks, In the end, I finished this this image by rendering a matcap and painting transparencies and reflections in Photoshop. But, I will try enabling ‘Show Backface’ to get this material working for the next time I need to render glass.

How do you even render a matcap?

Just get it how you like in the viewport, press image so the extras aren’t showing then, instead of Render/F12, go to View>Viewport Render Image
image

Also, you could setup a node system if you have multiple objects and want to use different Matcaps.