Blender Launcher [Standalone Software Client]

Blender Launcher

Screenshots

What is it?

Blender Launcher is a standalone software client that provides with management of downloading and storing stable, daily and experimental builds of Blender 3D. It is a free open source project available for 64-bit Windows and Linux operating systems.

Why I need it?

The goal of Blender Launcher is to make it easier to stay up to date with latest features and improvements of Blender 3D while feeling safe using a stable releases. Been a minimalistic portable application it is a nice tool for organizing and daily use of evolving free and open source 3D creation suite.

What features it has?

Compared to it predecessor Blender Launcher introduces number of major improvements:

Core features:

  • Automatic checking of latest builds
  • Fast access of favorite build via tray context menu or by middle click on tray icon
  • Register .blend file extension for preferred build
  • Create desktop shortcut
  • Indication of running builds and its number of instances

Useful Links

Latest release:

:arrow_down: Download Blender Launcher v1.5.0 from GitHub

Support:

:money_with_wings: Buy Blender Launcher on Gumroad

Documentation:

:compass: Follow Installation instructions and notes on Wiki

Development:

:hammer_and_wrench: TODOs and new features on Trello board

Source Code:

:page_facing_up: Blender Launcher on GitHub


:sparkling_heart: Appreciate any feedback and pull requests! Have a good day!

17 Likes

This is the best thing since sliced bread! The new version is a great upgrade over the old one, and I already loved the old one. Thank you.

1 Like

Is there an option to use my existing installation folder? With the old Blender Version Manager that was possible, but with this version it seems to want an empty Library folder and ignores any installations if I select the old one. I assume I would have to re-install any Blenders I already have, plus reinstall addons & reconfigure Blender.

Or am I wrong?

Hi!
If you want to use builds from BVM you should move them inside daily or custom folder (and restart applciation):

|-- Library Folder
    |-- .temp
    |-- custom
    |-- daily
    |-- experimental
    |-- stable

About addons and settings - they laid under configuration folder according to the Blender documentation. So, they not bound to build, only to version (i.e. 2.79, 2.80, 2.81 etc.).

Thanks for the explanation Oleg. Re the addons etc, I thought that when I upgraded from 2.80 to 2.81, then 2.81 to 2.82 these were copied to the new installation, but to be honest I can’t remember.

1 Like

When you start a new version of blender for the first time it will give you the option of copying over all your previous settings/add-ons from an older version, if present. Blender saves configuration/add-ons for each version of blender that you run in the %appdata% folder. So even if you download a daily version of 2.90, for example, you will have the exact same settings/addons/startup file/etc and don’t need to worry about anything.

1 Like
β–ˆβ–ˆβ•—   β–ˆβ–ˆβ•— β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ•— β–ˆβ–ˆβ•—   β–ˆβ–ˆβ•—    β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ•—  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ•—  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ•—β–ˆβ–ˆβ•—  β–ˆβ–ˆβ•—    β–ˆβ–ˆβ•—β–ˆβ–ˆβ•—
β•šβ–ˆβ–ˆβ•— β–ˆβ–ˆβ•”β•β–ˆβ–ˆβ•”β•β•β•β–ˆβ–ˆβ•—β–ˆβ–ˆβ•‘   β–ˆβ–ˆβ•‘    β–ˆβ–ˆβ•”β•β•β–ˆβ–ˆβ•—β–ˆβ–ˆβ•”β•β•β•β–ˆβ–ˆβ•—β–ˆβ–ˆβ•”β•β•β•β•β•β–ˆβ–ˆβ•‘ β–ˆβ–ˆβ•”β•    β–ˆβ–ˆβ•‘β–ˆβ–ˆβ•‘
 β•šβ–ˆβ–ˆβ–ˆβ–ˆβ•”β• β–ˆβ–ˆβ•‘   β–ˆβ–ˆβ•‘β–ˆβ–ˆβ•‘   β–ˆβ–ˆβ•‘    β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ•”β•β–ˆβ–ˆβ•‘   β–ˆβ–ˆβ•‘β–ˆβ–ˆβ•‘     β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ•”β•     β–ˆβ–ˆβ•‘β–ˆβ–ˆβ•‘
  β•šβ–ˆβ–ˆβ•”β•  β–ˆβ–ˆβ•‘   β–ˆβ–ˆβ•‘β–ˆβ–ˆβ•‘   β–ˆβ–ˆβ•‘    β–ˆβ–ˆβ•”β•β•β–ˆβ–ˆβ•—β–ˆβ–ˆβ•‘   β–ˆβ–ˆβ•‘β–ˆβ–ˆβ•‘     β–ˆβ–ˆβ•”β•β–ˆβ–ˆβ•—     β•šβ•β•β•šβ•β•
   β–ˆβ–ˆβ•‘   β•šβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ•”β•β•šβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ•”β•    β–ˆβ–ˆβ•‘  β–ˆβ–ˆβ•‘β•šβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ•”β•β•šβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ•—β–ˆβ–ˆβ•‘  β–ˆβ–ˆβ•—    β–ˆβ–ˆβ•—β–ˆβ–ˆβ•—
   β•šβ•β•    β•šβ•β•β•β•β•β•  β•šβ•β•β•β•β•β•     β•šβ•β•  β•šβ•β• β•šβ•β•β•β•β•β•  β•šβ•β•β•β•β•β•β•šβ•β•  β•šβ•β•    β•šβ•β•β•šβ•β•
3 Likes

Thanks. I just tried by installing the latest 2.83 daily. The addons etc were copied.

1 Like

anyone getting a Connection error status? Everything was fine yesterday. When I right click to quit it doesn’t quit either.

Version 1.0.0
Here’s what’s in the BL.LOG file:

2020-05-29 22:36:44,714 - main - ERROR - Windows
Traceback (most recent call last):
File β€œwindows\main_window.py”, line 241, in quit
AttributeError: β€˜BlenderLauncher’ object has no attribute β€˜timer’

Hi!
Connection Error is an expected behavior when something fails with scraping data from blender.org, so it is outside of launcher. You should just wait for next update loop.
However, an error is not supposed to happen when quitting, so thanks for report!

Ok, I looked at what’s happening and it seems there is now new version naming for blender builds and its broke everything. Fix is coming.

Blender Launcher 1.1.0 released!

Fixed:

  • Downloading raises SSL Certificate error on some Linux distributions
  • New version naming of builds raises connection error
  • Finished timer caused error on quitting

New:

  • Launching new instances of Blender Launcher will open existing one
  • Automatic cleaning of .temp folder
5 Likes

Thank you so much!

Yesssss

I can’t get ’ Launch When System Starts’ to work in 1.1.0, It used to work in 1.0.0
The option is active but it never starts.

Hi!
Have you checked the Startup tab of Task Manager?
If it is not there or manually turned off then it will not work I guess.
Or maybe you changed Blender Launcher.exe location?

It’s not in the startup list. When I installed 1.1.0 I put it in a new folder, then deleted 1.0.0. However I found a copy of 1.0.0 executable lurking in the download folder. That’s now also deleted, but 1.1.0 still doesn’t put itself in startup - I’ll add to startup manually

Curious, I’d like to modify Blender Launcher to deploy a custom build of blender, whats the best way to go about this? Were can I make the modifcations in the source code? So, instead of point to url β€œhttps://builder.blender.org/download/” it point to a hosted site with my custom complied version of Blender.

Weird. The only situation I can imagine is when it added to Startup and shown in Task Manager but disabled by system. Maybe there is something in BL.log file.

Hi!

Well, you should take a look at scraper.py where all scraping functionality is lying. The code is not well documented, feel free to ask questions with PM.

Basically, the scrap_download_links function search through available links to builds by given URL and new_blender_build make a BuildInfo object that library can draw. However, it is bound to build type and naming parsing. So, I think you can pretty quickly reverse engineer this part.

It’s working now after manually adding it to startup. I’ll check next time I install an update and make sure I sue the same location & filename.
Thanks for the assistance. :+1: