keKit for Blender (2.8+)

Not sure if this is a bug or not. But noticed a little weird behavior when testing/messing with the select side of mouse.


Hmm, it is not supposed to “extend” selections.

EDIT: Ah ok, I see now. The “side of active” part under the hood, actually only works with verts. So when using edges, the furthest vert of the active edge is used, and thus all verts -to the side of this vert- is selected, in the case above, all of them ;> So , “working as intended”. This is needed for face mode to work well. but could probably be swapped for edge mode…

EDIT3: Hmm no, i think i prefer the current functionality (“including” the entire edge “area” ). You can use vert mode if you want vert “precision” ;>
This is what the (imho, worse) alternative would be:


Yeah! What you show is there is what I expected I think.

Or I guess it’s what you had? Lol. Not sure. Yeah overall your one was working great. Or I just need to use vert or something yeah if I want exact.

Yeah the default one in blender uses vert yes. I wrote a little script that also converts / selects the faces to once side for quick mirroring.

But I like your tool for various actions as well. Having to always use a vert then convert to edges or faces gets annoying normally.

New Add-on is done! JFYI ;>


Hi there is a problem with the rotation tool when is used in local coordinates mode… it is not consistent with the camera orientation. Same for the move tool.

1 Like

Hey. Yes, confirmed. I’ll fix stand-alone VP-tools ;>


hi! thanks for new addon! also let me please report a bug in Kekit (i suppose a bug…) - 3d cursor fit and align partially work or doesnt work at all on objects with modifiers (placement on face centers)…


hey, hmm, I will check it out!
edit: I was reminded why that was: The raycasting for un-evaluated indices is bugged afaict. So, crappy work-around time ;>…bugfix release coming shortly.
edit2: It’s out!


Thank you for your last update, the new ‘move in 2 axis in local mode’ works like charm.

Would it be possible to have an option to hide this panel from the interface.

Thank you again for making this amazing add-on ! :+1:

hey, thx!

Hiding the icons, this is already possible: keKit for Blender (2.8+) - #834 by Kiellog

edit: I think I’ll add some info in the mouse-over pop-up info for these.

Thank you for some reason I couldn’t see it !

By the way I found this script in my script library. I don’t know where I got it from but it is something similar to ‘set reference system’ in Modo where you can temporarily align the world origin to a specific object so it makes easy to model objects that are randomly positioned in space. This is the tool in action:

I’ve attached the script. Maybe you can integrate it in keKit and make it more user friendly.

Thanks !

rotate_around_active_and (14.0 KB)

No problem!

Reg. the script:
Hmm. Yeah, I am familiar with modos “local space mode”, but, not sure this particular solution is how I’d want to do it. Or if I want to do it ;>

Though, you might check with the original author with feature requests ?


Hi guys! could you plz help me? xD im stuck on 2.83 cause of old knife project method, i really really dont like new one (, so could anyone plz explain me is it possible to “extract” old method from code and use it anyhow in new blender builds or its to complicated?
Have a good day. Long time no comments…
@Kiellog thank you for 1456!

1 Like

I don’t have much interest in the knife project changes personally. Pass for now.
(I Can’t help you with a custom build either. sry!)

1 Like

Perhaps you could go into the commits at and then go to the code comparison to see what was altered and bring this back (maybe name it as a custom tool afterwards as to not mess up the GSOC knife tool?).

1 Like

@Kiellog Is it possible that the TT move and similar tools don’t function on Grease Pencil objects, or is this some defect with my setup?
Great tools by the way. Embarrassingly I’ve been ignoring this addon for ages, only to now find out that much of the stuff I’d hacked together in Pie Menu Editor has been done better in KeKit :grimacing:

1 Like

Thanks! ;>

reg, TT tools & Gpencil… there seems to be something bugged. Could’ve sworn it was working at some point, but I never use Gpencil so I wouldn’t notice any issues :wink:
(So yeah, it should work. I’ll fix.)


Hi - Just to let you know there is still a small problem with the move/rotate 2 axis. When in local mode it works as expected thanks to your last patch, the problem now is that if I activate it and while is on I decide to lock in one axis then the local mode doesn’t work and goes back to global mode. Is there a way to fix it ?

Thank you, I appreciate it ! :slight_smile:

1 Like

I’ll need some clarifications first, to avoid misunderstanding ;>
Which tool exactly? (Do you mean VPTransform Move & Rotate? Are you using TT Toggle?)

1 Like

Yes VPTransform when transform orientation is in Local mode. It works but if you press middle mouse button when the tool is active (to lock one axis) it does it in Global mode.